summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-05-13 13:25:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-05-13 16:07:09 +0200
commitcbe2b8f6cd4b89c9187c5c4dbabfccccf89f212e (patch)
treed23ac56cbcb9ae96caa4b36aa8ae1bb9b1d06211 /dev-ros/test_roscpp
parentdev-ros/test_rosbag_storage: Bump to 1.15.4. (diff)
downloadgentoo-cbe2b8f6cd4b89c9187c5c4dbabfccccf89f212e.tar.gz
gentoo-cbe2b8f6cd4b89c9187c5c4dbabfccccf89f212e.tar.bz2
gentoo-cbe2b8f6cd4b89c9187c5c4dbabfccccf89f212e.zip
dev-ros/test_roscpp: Bump to 1.15.4.
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_roscpp')
-rw-r--r--dev-ros/test_roscpp/Manifest1
-rw-r--r--dev-ros/test_roscpp/test_roscpp-1.15.4.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/test_roscpp/Manifest b/dev-ros/test_roscpp/Manifest
index 3d0a1ebaa18a..61884545d536 100644
--- a/dev-ros/test_roscpp/Manifest
+++ b/dev-ros/test_roscpp/Manifest
@@ -1 +1,2 @@
DIST ros_comm-1.14.3.tar.gz 1045287 BLAKE2B c079983aa730e70028d1bf2c365d01d99ce09ced0c0f6443b18f9d0fb83715f6af4b313d6db4eb99dcc10052c81fa3e6560e7b3591b2fbe14b9ec20fac24babe SHA512 52df24f10f476697ee6fa340da354b45431f35018a25e2674dc9306f175929a4b0368753503ea143f87aeb4945a2e67c37f83d833f54b53f9a76a81022c280a3
+DIST ros_comm-1.15.4.tar.gz 1071246 BLAKE2B 57867c192bfd48f3a0534762808c668031081a6155510879e68f9618226b9c5eff0d5fc9ec0e7ec8d0cc1f0d74794a4e55151036275ae6fc5bb613cc42137ddc SHA512 f92233cbf5ee97832023545730d3e756dfa08507072c074ac3e0763db1c2c2ab9fcbb0c90995a0c5d43f0ddc2ee528c185173a664b19abe4f8159aa3f3cb20dc
diff --git a/dev-ros/test_roscpp/test_roscpp-1.15.4.ebuild b/dev-ros/test_roscpp/test_roscpp-1.15.4.ebuild
new file mode 100644
index 000000000000..e1720ee72889
--- /dev/null
+++ b/dev-ros/test_roscpp/test_roscpp-1.15.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for roscpp"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-ros/roscpp
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/boost:=[threads]
+ test? (
+ dev-cpp/gtest
+ )
+"
+REQUIRED_USE="test? ( ros_messages_cxx )"