summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-08-05 18:29:16 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-08-05 19:55:00 +0200
commit1fe570906e3205cfaac2b434ecf38e645481c651 (patch)
tree7f40637b68edaf43d0c38d75e8951e982005605a /dev-ros/test_roscpp
parentdev-ros/cv_bridge: add missing test deps (diff)
downloadgentoo-1fe570906e3205cfaac2b434ecf38e645481c651.tar.gz
gentoo-1fe570906e3205cfaac2b434ecf38e645481c651.tar.bz2
gentoo-1fe570906e3205cfaac2b434ecf38e645481c651.zip
dev-ros/test_roscpp: fix tests
Closes: https://bugs.gentoo.org/734690 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/test_roscpp')
-rw-r--r--dev-ros/test_roscpp/files/tests.patch12
-rw-r--r--dev-ros/test_roscpp/test_roscpp-1.15.8.ebuild6
-rw-r--r--dev-ros/test_roscpp/test_roscpp-9999.ebuild6
3 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/test_roscpp/files/tests.patch b/dev-ros/test_roscpp/files/tests.patch
new file mode 100644
index 000000000000..80c18962dee0
--- /dev/null
+++ b/dev-ros/test_roscpp/files/tests.patch
@@ -0,0 +1,12 @@
+Index: test_roscpp/test/src/CMakeLists.txt
+===================================================================
+--- test_roscpp.orig/test/src/CMakeLists.txt
++++ test_roscpp/test/src/CMakeLists.txt
+@@ -290,6 +290,7 @@ if(TARGET tests)
+ ${PROJECT_NAME}-left_right
+ ${PROJECT_NAME}-string_msg_expect
+ ${PROJECT_NAME}-publisher
++ ${PROJECT_NAME}-publisher_rate
+ ${PROJECT_NAME}-subscriber
+ ${PROJECT_NAME}-stamped_topic_statistics_empty_timestamp
+ ${PROJECT_NAME}-topic_statistic_frequency
diff --git a/dev-ros/test_roscpp/test_roscpp-1.15.8.ebuild b/dev-ros/test_roscpp/test_roscpp-1.15.8.ebuild
index d1b28ba0acaa..39bfc4bf09a4 100644
--- a/dev-ros/test_roscpp/test_roscpp-1.15.8.ebuild
+++ b/dev-ros/test_roscpp/test_roscpp-1.15.8.ebuild
@@ -28,3 +28,9 @@ DEPEND="${RDEPEND}
)
"
REQUIRED_USE="test? ( ros_messages_cxx )"
+PATCHES=( "${FILESDIR}/tests.patch" )
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}
diff --git a/dev-ros/test_roscpp/test_roscpp-9999.ebuild b/dev-ros/test_roscpp/test_roscpp-9999.ebuild
index d1b28ba0acaa..39bfc4bf09a4 100644
--- a/dev-ros/test_roscpp/test_roscpp-9999.ebuild
+++ b/dev-ros/test_roscpp/test_roscpp-9999.ebuild
@@ -28,3 +28,9 @@ DEPEND="${RDEPEND}
)
"
REQUIRED_USE="test? ( ros_messages_cxx )"
+PATCHES=( "${FILESDIR}/tests.patch" )
+
+src_test() {
+ export ROS_PACKAGE_PATH="${S}:${ROS_PACKAGE_PATH}"
+ ros-catkin_src_test
+}