summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 15:19:31 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 15:26:44 +0200
commitecbcd9065b0c1f8eec0a7892f9c219a09db2eba6 (patch)
tree24cb084d21e6bcc01b77c10ca2b222d84b6c8ea8 /dev-ros/rqt_shell
parentdev-ros/rqt_srv: Remove old (diff)
downloadgentoo-ecbcd9065b0c1f8eec0a7892f9c219a09db2eba6.tar.gz
gentoo-ecbcd9065b0c1f8eec0a7892f9c219a09db2eba6.tar.bz2
gentoo-ecbcd9065b0c1f8eec0a7892f9c219a09db2eba6.zip
dev-ros/rqt_shell: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_shell')
-rw-r--r--dev-ros/rqt_shell/Manifest1
-rw-r--r--dev-ros/rqt_shell/rqt_shell-0.4.10.ebuild23
-rw-r--r--dev-ros/rqt_shell/rqt_shell-9999.ebuild5
3 files changed, 26 insertions, 3 deletions
diff --git a/dev-ros/rqt_shell/Manifest b/dev-ros/rqt_shell/Manifest
index 0d4b82d3832b..18048f11373c 100644
--- a/dev-ros/rqt_shell/Manifest
+++ b/dev-ros/rqt_shell/Manifest
@@ -1,2 +1,3 @@
+DIST rqt_shell-0.4.10.tar.gz 6966 BLAKE2B 51e42222083ec64cdd991f9a3b0096bca19cd4b7f9083a4286d7ded0f2695382c132edd90af47c59c69e1ed1f9e35e5ade4469c40e8a072855d63f17ac4f0da9 SHA512 7562ac0aba35ad75dc884a81a737669e473516cdbc3c7207657d6fb24ea82aacb340eee68eed346fed57bca33bc878008fdd4569d6113df2609012dfedcaecc6
DIST rqt_shell-0.4.8.tar.gz 6810 BLAKE2B 9156ee96f716ee74613ea048dc21e9f9653b14eba3064d05cb3fc2f24f3ea189a9908cb42c1adbf132747ddc71adbf8d002721d3b94f192c72c9c6a02fadeb21 SHA512 c71653fc8f50f9c67b963b3e6ba018d8730c749f0274051e891c9bea19fcd337186838fa9dfc7152cff6a2cf0921aee6aa4b27d7c209888759c80993fbcf9257
DIST rqt_shell-0.4.9.tar.gz 6860 BLAKE2B 58a9e7d31786e94cd3d4370c647497af2ba15ee18c0c36b510f02828fac5491928eab7afcd183e46dbcd379579cc288bce334770b601f9a697021961c048e360 SHA512 105a8f0a9a5549f5abe57ff3f48c3d6c9621eedb676db9afe9980aba20bbeca58736e0eef4df86a46862e8c56bf11f2b439ccb2bafb3e3e1eaee76899e956c47
diff --git a/dev-ros/rqt_shell/rqt_shell-0.4.10.ebuild b/dev-ros/rqt_shell/rqt_shell-0.4.10.ebuild
new file mode 100644
index 000000000000..7f5c385e40f2
--- /dev/null
+++ b/dev-ros/rqt_shell/rqt_shell-0.4.10.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_shell"
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin providing an interactive shell"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_shell/rqt_shell-9999.ebuild b/dev-ros/rqt_shell/rqt_shell-9999.ebuild
index 7cf7b1be6b20..7f5c385e40f2 100644
--- a/dev-ros/rqt_shell/rqt_shell-9999.ebuild
+++ b/dev-ros/rqt_shell/rqt_shell-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
KEYWORDS="~amd64"
ROS_REPO_URI="https://github.com/ros-visualization/rqt_shell"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin