summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-26 09:19:35 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-26 09:24:13 +0100
commit19c45448b36bb5b58ef719658484eb9427e2c5db (patch)
tree020ab6fa325ac33c6a0f0b2454bb346d7ddf2ceb /dev-ros/rqt_nav_view/rqt_nav_view-0.5.6.ebuild
parentdev-ros/rqt_moveit: Bump to 0.5.6. (diff)
downloadgentoo-19c45448b36bb5b58ef719658484eb9427e2c5db.tar.gz
gentoo-19c45448b36bb5b58ef719658484eb9427e2c5db.tar.bz2
gentoo-19c45448b36bb5b58ef719658484eb9427e2c5db.zip
dev-ros/rqt_nav_view: Bump to 0.5.6.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ros/rqt_nav_view/rqt_nav_view-0.5.6.ebuild')
-rw-r--r--dev-ros/rqt_nav_view/rqt_nav_view-0.5.6.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/rqt_nav_view/rqt_nav_view-0.5.6.ebuild b/dev-ros/rqt_nav_view/rqt_nav_view-0.5.6.ebuild
new file mode 100644
index 000000000000..fc44cd6cc6fa
--- /dev/null
+++ b/dev-ros/rqt_nav_view/rqt_nav_view-0.5.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a gui for viewing navigation maps and paths"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"