summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-30 18:11:33 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-30 18:43:49 +0200
commit74befb38f65984d2e57a7241821aafadd8eba5ad (patch)
treeb987ff06c6e383fabcde3c1ff50aba61cddfc246 /dev-ros/rostest/rostest-1.13.1.ebuild
parentdev-ros/rosservice: Bump to 1.13.1. (diff)
downloadgentoo-74befb38f65984d2e57a7241821aafadd8eba5ad.tar.gz
gentoo-74befb38f65984d2e57a7241821aafadd8eba5ad.tar.bz2
gentoo-74befb38f65984d2e57a7241821aafadd8eba5ad.zip
dev-ros/rostest: Bump to 1.13.1.
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ros/rostest/rostest-1.13.1.ebuild')
-rw-r--r--dev-ros/rostest/rostest-1.13.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/rostest/rostest-1.13.1.ebuild b/dev-ros/rostest/rostest-1.13.1.ebuild
new file mode 100644
index 000000000000..c46bbf042402
--- /dev/null
+++ b/dev-ros/rostest/rostest-1.13.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="Integration test suite based on roslaunch that is compatible with xUnit frameworks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}"
+RDEPEND="${RDEPEND}
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roslaunch[${PYTHON_USEDEP}]
+ dev-ros/rosmaster[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ test? (
+ ${RDEPEND}
+ dev-cpp/gtest
+ )"