summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-11 10:13:57 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-11 10:14:08 +0100
commit1781d604ee0c6a5094e09fe607dc7dedffa1e2a0 (patch)
treeffad54507a34387d15e9e379c9e0b235125dde66 /dev-ros/roslib
parentdev-ros/rosbash: remove old (diff)
downloadgentoo-1781d604ee0c6a5094e09fe607dc7dedffa1e2a0.tar.gz
gentoo-1781d604ee0c6a5094e09fe607dc7dedffa1e2a0.tar.bz2
gentoo-1781d604ee0c6a5094e09fe607dc7dedffa1e2a0.zip
dev-ros/roslib: Patch env hooks to work better on Gentoo.
Use env python instead of hardcoder python version at build time. Honour CATKIN_PREFIX_PATH. Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ros/roslib')
-rw-r--r--dev-ros/roslib/files/envhook.patch34
-rw-r--r--dev-ros/roslib/roslib-1.14.0-r1.ebuild (renamed from dev-ros/roslib/roslib-1.14.0.ebuild)1
-rw-r--r--dev-ros/roslib/roslib-9999.ebuild1
3 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/roslib/files/envhook.patch b/dev-ros/roslib/files/envhook.patch
new file mode 100644
index 000000000000..d4e24e937351
--- /dev/null
+++ b/dev-ros/roslib/files/envhook.patch
@@ -0,0 +1,34 @@
+Use env python for running python so that it uses the proper version on Gentoo.
+Honour CATKIN_PREFIX_PATH gentoo addition.
+
+Index: roslib/env-hooks/10.ros.sh.em
+===================================================================
+--- roslib.orig/env-hooks/10.ros.sh.em
++++ roslib/env-hooks/10.ros.sh.em
+@@ -1,8 +1,5 @@
+ # generated from ros/env-hooks/10.ros.sh.em
+
+-# scrub old ROS bin dirs, to avoid accidentally finding the wrong executables
+-export PATH="`@(PYTHON_EXECUTABLE) -c \"import os; print(os.pathsep.join([x for x in \\\"$PATH\\\".split(os.pathsep) if not any([d for d in ['cturtle', 'diamondback', 'electric', 'fuerte'] if d in x])]))\"`"
+-
+ @{
+ # This is a build-time environment variable which allows a build engineer to override the expected
+ # ROS_DISTRO value for a workspace, for example to deliberately use a newer version of roslib with
+@@ -19,7 +16,7 @@ export ROS_DISTRO=@(ROS_DISTRO)
+ PYTHON_CODE_BUILD_ROS_PACKAGE_PATH=$(cat <<EOF
+ from __future__ import print_function
+ import os
+-env_name = 'CMAKE_PREFIX_PATH'
++env_name = 'CATKIN_PREFIX_PATH'
+ paths = [path for path in os.environ[env_name].split(os.pathsep)] if env_name in os.environ and os.environ[env_name] != '' else []
+ workspaces = [path for path in paths if os.path.exists(os.path.join(path, '.catkin'))]
+ paths = []
+@@ -38,7 +35,7 @@ for workspace in workspaces:
+ print(os.pathsep.join(paths))
+ EOF
+ )
+-export ROS_PACKAGE_PATH="`@(PYTHON_EXECUTABLE) -c \"$PYTHON_CODE_BUILD_ROS_PACKAGE_PATH\"`"
++export ROS_PACKAGE_PATH="`/usr/bin/env python -c \"$PYTHON_CODE_BUILD_ROS_PACKAGE_PATH\"`"
+
+ @[if DEVELSPACE]@
+ # env variables in develspace
diff --git a/dev-ros/roslib/roslib-1.14.0.ebuild b/dev-ros/roslib/roslib-1.14.0-r1.ebuild
index 0ba96a53071e..1866c312cfe9 100644
--- a/dev-ros/roslib/roslib-1.14.0.ebuild
+++ b/dev-ros/roslib/roslib-1.14.0-r1.ebuild
@@ -25,3 +25,4 @@ DEPEND="${RDEPEND}
dev-cpp/gtest
dev-python/nose[${PYTHON_USEDEP}]
)"
+PATCHES=( "${FILESDIR}/envhook.patch" )
diff --git a/dev-ros/roslib/roslib-9999.ebuild b/dev-ros/roslib/roslib-9999.ebuild
index 0ba96a53071e..1866c312cfe9 100644
--- a/dev-ros/roslib/roslib-9999.ebuild
+++ b/dev-ros/roslib/roslib-9999.ebuild
@@ -25,3 +25,4 @@ DEPEND="${RDEPEND}
dev-cpp/gtest
dev-python/nose[${PYTHON_USEDEP}]
)"
+PATCHES=( "${FILESDIR}/envhook.patch" )