summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-06 17:11:58 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-06 20:23:29 +0100
commit004e8fa560114aebec58d0d60234644aa5c7fda5 (patch)
treebf94a399fc8b9f44f51bdb7f3ba7e3945dc99fdd /dev-ros/ros_environment
parentdev-ros/roslib: follow upstream and depend on ros_environment (diff)
downloadgentoo-004e8fa560114aebec58d0d60234644aa5c7fda5.tar.gz
gentoo-004e8fa560114aebec58d0d60234644aa5c7fda5.tar.bz2
gentoo-004e8fa560114aebec58d0d60234644aa5c7fda5.zip
dev-ros/ros_environment: Still honour CMAKE_PREFIX_PATH for ROS standard methods.
Closes: https://bugs.gentoo.org/624924 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ros/ros_environment')
-rw-r--r--dev-ros/ros_environment/files/catkinprefixpath.patch19
-rw-r--r--dev-ros/ros_environment/ros_environment-1.2.0-r1.ebuild (renamed from dev-ros/ros_environment/ros_environment-1.2.0.ebuild)0
2 files changed, 13 insertions, 6 deletions
diff --git a/dev-ros/ros_environment/files/catkinprefixpath.patch b/dev-ros/ros_environment/files/catkinprefixpath.patch
index ba78a70c2a49..67f16ec9348a 100644
--- a/dev-ros/ros_environment/files/catkinprefixpath.patch
+++ b/dev-ros/ros_environment/files/catkinprefixpath.patch
@@ -1,13 +1,20 @@
-Index: ros_environment-9999/env-hooks/1.ros_package_path.sh.em
+Support CATKIN_PREFIX_PATH; let CMAKE_PREFIX_PATH come first, so that standard ROS methods still work even if we do not
+use them.
+
+Index: ros_environment-1.2.0/env-hooks/1.ros_package_path.sh.em
===================================================================
---- ros_environment-9999.orig/env-hooks/1.ros_package_path.sh.em
-+++ ros_environment-9999/env-hooks/1.ros_package_path.sh.em
-@@ -4,7 +4,7 @@
+--- ros_environment-1.2.0.orig/env-hooks/1.ros_package_path.sh.em
++++ ros_environment-1.2.0/env-hooks/1.ros_package_path.sh.em
+@@ -4,8 +4,10 @@
PYTHON_CODE_BUILD_ROS_PACKAGE_PATH=$(cat <<EOF
from __future__ import print_function
import os
-env_name = 'CMAKE_PREFIX_PATH'
-+env_name = 'CATKIN_PREFIX_PATH'
- paths = [path for path in os.environ[env_name].split(os.pathsep)] if env_name in os.environ and os.environ[env_name] != '' else []
+-paths = [path for path in os.environ[env_name].split(os.pathsep)] if env_name in os.environ and os.environ[env_name] != '' else []
++env_names = [ 'CMAKE_PREFIX_PATH', 'CATKIN_PREFIX_PATH' ]
++paths = []
++for env_name in env_names:
++ paths += [path for path in os.environ[env_name].split(os.pathsep)] if env_name in os.environ and os.environ[env_name] != '' else []
workspaces = [path for path in paths if os.path.exists(os.path.join(path, '.catkin'))]
paths = []
+ for workspace in workspaces:
diff --git a/dev-ros/ros_environment/ros_environment-1.2.0.ebuild b/dev-ros/ros_environment/ros_environment-1.2.0-r1.ebuild
index 14906c3050db..14906c3050db 100644
--- a/dev-ros/ros_environment/ros_environment-1.2.0.ebuild
+++ b/dev-ros/ros_environment/ros_environment-1.2.0-r1.ebuild