summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-04-07 16:07:12 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-04-07 16:08:19 +0200
commitaf64b2505c2e0a0f261f15f327fcbd5b09dadaf2 (patch)
tree5985d6a750002b20cc948a2f112009e3b6d23b88 /dev-ros/pluginlib/pluginlib-1.12.0-r1.ebuild
parentdev-ros/class_loader: bump to 0.4.0 (diff)
downloadgentoo-af64b2505c2e0a0f261f15f327fcbd5b09dadaf2.tar.gz
gentoo-af64b2505c2e0a0f261f15f327fcbd5b09dadaf2.tar.bz2
gentoo-af64b2505c2e0a0f261f15f327fcbd5b09dadaf2.zip
dev-ros/pluginlib: better deps
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-ros/pluginlib/pluginlib-1.12.0-r1.ebuild')
-rw-r--r--dev-ros/pluginlib/pluginlib-1.12.0-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ros/pluginlib/pluginlib-1.12.0-r1.ebuild b/dev-ros/pluginlib/pluginlib-1.12.0-r1.ebuild
new file mode 100644
index 000000000000..5346810670b3
--- /dev/null
+++ b/dev-ros/pluginlib/pluginlib-1.12.0-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/pluginlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+ROS_SUBDIR="${PN}"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/class_loader-0.3.5:=
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/catkin_prefix_path2.patch" )