summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-24 10:45:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-24 10:45:21 +0200
commit567237c2b0b06e6a7a4dbc430b853e6845cf619d (patch)
tree0bf3d1d81f4ef06cf628a047cbd2b1cec4d57884 /dev-ros/message_to_tf/message_to_tf-0.2.0.ebuild
parentros-meta/vision_visp: Initial import. Ebuild by me. (diff)
downloadgentoo-567237c2b0b06e6a7a4dbc430b853e6845cf619d.tar.gz
gentoo-567237c2b0b06e6a7a4dbc430b853e6845cf619d.tar.bz2
gentoo-567237c2b0b06e6a7a4dbc430b853e6845cf619d.zip
dev-ros/message_to_tf: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/message_to_tf/message_to_tf-0.2.0.ebuild')
-rw-r--r--dev-ros/message_to_tf/message_to_tf-0.2.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/message_to_tf/message_to_tf-0.2.0.ebuild b/dev-ros/message_to_tf/message_to_tf-0.2.0.ebuild
new file mode 100644
index 000000000000..4c0669f4be85
--- /dev/null
+++ b/dev-ros/message_to_tf/message_to_tf-0.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_localization"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Translates pose information from different kind of common_msgs message types to tf"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/topic_tools
+"
+DEPEND="${RDEPEND}"