summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-09 13:35:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-09 13:45:30 +0200
commitdd3455fef4a8b50a140fb965b9eb274d8d54c1f7 (patch)
tree83fa8d622966965241dd7502eb1988381d254a09 /dev-ros/image_view
parentdev-ros/stereo_image_proc: Remove old (diff)
downloadgentoo-dd3455fef4a8b50a140fb965b9eb274d8d54c1f7.tar.gz
gentoo-dd3455fef4a8b50a140fb965b9eb274d8d54c1f7.tar.bz2
gentoo-dd3455fef4a8b50a140fb965b9eb274d8d54c1f7.zip
dev-ros/image_view: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/image_view')
-rw-r--r--dev-ros/image_view/image_view-1.15.2.ebuild8
-rw-r--r--dev-ros/image_view/image_view-9999.ebuild10
2 files changed, 9 insertions, 9 deletions
diff --git a/dev-ros/image_view/image_view-1.15.2.ebuild b/dev-ros/image_view/image_view-1.15.2.ebuild
index e471e1508b6c..db425e971183 100644
--- a/dev-ros/image_view/image_view-1.15.2.ebuild
+++ b/dev-ros/image_view/image_view-1.15.2.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
@@ -26,9 +25,10 @@ RDEPEND="
dev-ros/rosconsole
dev-libs/console_bridge:=
dev-ros/roscpp
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}"
diff --git a/dev-ros/image_view/image_view-9999.ebuild b/dev-ros/image_view/image_view-9999.ebuild
index b9c0dff05bac..db425e971183 100644
--- a/dev-ros/image_view/image_view-9999.ebuild
+++ b/dev-ros/image_view/image_view-9999.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
@@ -26,9 +25,10 @@ RDEPEND="
dev-ros/rosconsole
dev-libs/console_bridge:=
dev-ros/roscpp
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
dev-ros/stereo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/std_srvs[${CATKIN_MESSAGES_CXX_USEDEP}]
- dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}"