summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-07-18 13:45:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-07-18 14:13:24 +0200
commit2c42eec7c31d5609bd83f9f117471b38cab383e8 (patch)
tree18a57f3a486d88964eab6a9508e4008e6f9a9244 /dev-ros/camera_calibration/camera_calibration-1.12.18.ebuild
parentros-meta/rosserial: reference rosserial_tivac as it is part of the metapackage. (diff)
downloadgentoo-2c42eec7c31d5609bd83f9f117471b38cab383e8.tar.gz
gentoo-2c42eec7c31d5609bd83f9f117471b38cab383e8.tar.bz2
gentoo-2c42eec7c31d5609bd83f9f117471b38cab383e8.zip
dev-ros/camera_calibration: Bump to 1.12.18.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/camera_calibration/camera_calibration-1.12.18.ebuild')
-rw-r--r--dev-ros/camera_calibration/camera_calibration-1.12.18.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/camera_calibration/camera_calibration-1.12.18.ebuild b/dev-ros/camera_calibration/camera_calibration-1.12.18.ebuild
new file mode 100644
index 000000000000..e94797f67763
--- /dev/null
+++ b/dev-ros/camera_calibration/camera_calibration-1.12.18.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Calibration of monocular or stereo cameras using a checkerboard calibration target"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge[${PYTHON_USEDEP}]
+ dev-ros/image_geometry[${PYTHON_USEDEP}]
+ || ( media-libs/opencv[python,${PYTHON_USEDEP}] media-libs/opencv[python,python_single_target_python2_7] )
+ dev-ros/message_filters[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/std_srvs[${PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"