summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 18:06:16 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 18:06:16 +0200
commitcde6e14be8d6b0d4903666756afd60923b0f6799 (patch)
tree6c9d4e667c4ae108ab406edae9b6c0fd2072c324 /dev-ros/actionlib/actionlib-9999.ebuild
parentros-meta/nodelet_core: Initial import. Ebuild by me. (diff)
downloadgentoo-cde6e14be8d6b0d4903666756afd60923b0f6799.tar.gz
gentoo-cde6e14be8d6b0d4903666756afd60923b0f6799.tar.bz2
gentoo-cde6e14be8d6b0d4903666756afd60923b0f6799.zip
dev-ros/actionlib: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/actionlib/actionlib-9999.ebuild')
-rw-r--r--dev-ros/actionlib/actionlib-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/actionlib/actionlib-9999.ebuild b/dev-ros/actionlib/actionlib-9999.ebuild
new file mode 100644
index 000000000000..b53dcae9597f
--- /dev/null
+++ b/dev-ros/actionlib/actionlib-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/actionlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a standardized interface for interfacing with preemptable tasks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads]
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"