summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2017-01-26 00:35:37 +1100
committerMichael Palimaka <kensington@gentoo.org>2017-01-26 00:36:29 +1100
commit7672298dd8d14ffeb2ae56a93ac5d0a421974cde (patch)
tree86d983b41e146ec21cc55f0a86497c1ca32463db /dev-qt
parentsci-mathematics/yacas: keyworded 1.6.1 ~x86 (diff)
downloadgentoo-7672298dd8d14ffeb2ae56a93ac5d0a421974cde.tar.gz
gentoo-7672298dd8d14ffeb2ae56a93ac5d0a421974cde.tar.bz2
gentoo-7672298dd8d14ffeb2ae56a93ac5d0a421974cde.zip
dev-qt/qtcore: backport patch from upstream that resolves various crashes
Gentoo-bug: 605672 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qtcore/qtcore-5.7.1-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-qt/qtcore/qtcore-5.7.1-r1.ebuild b/dev-qt/qtcore/qtcore-5.7.1-r1.ebuild
new file mode 100644
index 000000000000..d62b7b65965a
--- /dev/null
+++ b/dev-qt/qtcore/qtcore-5.7.1-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+QT5_MODULE="qtbase"
+inherit qt5-build
+
+DESCRIPTION="Cross-platform application development framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="icu systemd"
+
+# TODO after bug 581054: dev-libs/double-conversion:=
+DEPEND="
+ dev-libs/glib:2
+ >=dev-libs/libpcre-8.38[pcre16,unicode]
+ >=sys-libs/zlib-1.2.5
+ virtual/libiconv
+ icu? ( dev-libs/icu:= )
+ systemd? ( sys-apps/systemd:= )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-5.6.2-plugins.patch" )
+
+QT5_TARGET_SUBDIRS=(
+ src/tools/bootstrap
+ src/tools/moc
+ src/tools/rcc
+ src/corelib
+ src/tools/qlalr
+ doc
+)
+
+src_configure() {
+ local myconf=(
+ $(qt_use icu)
+ $(qt_use systemd journald)
+ )
+ qt5-build_src_configure
+}