summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-11 20:30:35 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-12 07:59:29 -0400
commit745c99eac91d81f589512d91e8a28f2c2215d75f (patch)
treea680fd3ebc7ef57e9fbb20adf69256c482e54aa0 /dev-qt
parentdev-qt/qtbase: tentatively enable unity build in live (diff)
downloadgentoo-745c99eac91d81f589512d91e8a28f2c2215d75f.tar.gz
gentoo-745c99eac91d81f589512d91e8a28f2c2215d75f.tar.bz2
gentoo-745c99eac91d81f589512d91e8a28f2c2215d75f.zip
dev-qt/qttools: disable unity build with USE=designer
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qttools/qttools-6.6.9999.ebuild2
-rw-r--r--dev-qt/qttools/qttools-6.7.9999.ebuild2
-rw-r--r--dev-qt/qttools/qttools-6.9999.ebuild2
3 files changed, 6 insertions, 0 deletions
diff --git a/dev-qt/qttools/qttools-6.6.9999.ebuild b/dev-qt/qttools/qttools-6.6.9999.ebuild
index df27a0546248..6b0169168b8d 100644
--- a/dev-qt/qttools/qttools-6.6.9999.ebuild
+++ b/dev-qt/qttools/qttools-6.6.9999.ebuild
@@ -85,6 +85,8 @@ src_configure() {
# to lag behind and bundled may work out better for now
# https://github.com/litehtml/litehtml/issues/266
$(usev assistant -DCMAKE_DISABLE_FIND_PACKAGE_litehtml=ON)
+
+ $(usev designer -DQT_UNITY_BUILD=OFF) # fails to build (QTBUG-122634)
)
qt6-build_src_configure
diff --git a/dev-qt/qttools/qttools-6.7.9999.ebuild b/dev-qt/qttools/qttools-6.7.9999.ebuild
index f71abecec56e..6156f4c02a83 100644
--- a/dev-qt/qttools/qttools-6.7.9999.ebuild
+++ b/dev-qt/qttools/qttools-6.7.9999.ebuild
@@ -85,6 +85,8 @@ src_configure() {
# to lag behind and bundled may work out better for now
# https://github.com/litehtml/litehtml/issues/266
$(usev assistant -DCMAKE_DISABLE_FIND_PACKAGE_litehtml=ON)
+
+ $(usev designer -DQT_UNITY_BUILD=OFF) # fails to build (QTBUG-122634)
)
qt6-build_src_configure
diff --git a/dev-qt/qttools/qttools-6.9999.ebuild b/dev-qt/qttools/qttools-6.9999.ebuild
index f71abecec56e..6156f4c02a83 100644
--- a/dev-qt/qttools/qttools-6.9999.ebuild
+++ b/dev-qt/qttools/qttools-6.9999.ebuild
@@ -85,6 +85,8 @@ src_configure() {
# to lag behind and bundled may work out better for now
# https://github.com/litehtml/litehtml/issues/266
$(usev assistant -DCMAKE_DISABLE_FIND_PACKAGE_litehtml=ON)
+
+ $(usev designer -DQT_UNITY_BUILD=OFF) # fails to build (QTBUG-122634)
)
qt6-build_src_configure