summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2021-07-11 07:29:54 +0200
committerDavide Pesavento <pesa@gentoo.org>2021-07-11 07:29:54 +0200
commit69c7ab38c931d19f61adb59bebadecc2ca598632 (patch)
tree1042c66414f707145bd281a4c7474241a0122f4e /dev-qt
parentdev-qt/qt-creator: add 4.15.1 (diff)
downloadgentoo-69c7ab38c931d19f61adb59bebadecc2ca598632.tar.gz
gentoo-69c7ab38c931d19f61adb59bebadecc2ca598632.tar.bz2
gentoo-69c7ab38c931d19f61adb59bebadecc2ca598632.zip
dev-qt/qt-creator: remove half-broken 4.12.3-r1
Bug: https://bugs.gentoo.org/757756 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Davide Pesavento <pesa@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qt-creator/Manifest1
-rw-r--r--dev-qt/qt-creator/files/qt-creator-4.12.0-dylib-fix.patch84
-rw-r--r--dev-qt/qt-creator/files/qt-creator-4.12.0-libclangformat-ide.patch64
-rw-r--r--dev-qt/qt-creator/metadata.xml2
-rw-r--r--dev-qt/qt-creator/qt-creator-4.12.3-r1.ebuild235
5 files changed, 0 insertions, 386 deletions
diff --git a/dev-qt/qt-creator/Manifest b/dev-qt/qt-creator/Manifest
index d88825421b0d..975ecb0a7d27 100644
--- a/dev-qt/qt-creator/Manifest
+++ b/dev-qt/qt-creator/Manifest
@@ -1,2 +1 @@
-DIST qt-creator-opensource-src-4.12.3.tar.xz 34351356 BLAKE2B 7f1302df09bae10ebe1882552abd25333788d7185280e9a0c73e7da6fb8b4d929da326e42c500385fba3e044350cd46c2cf2e33e49b0cca2d9c3b4d68693115d SHA512 48cd5839cff724300516f78deba3b1a7199d46d6f9a6a4c662bf2f581db167e4376a9bdd544544071591c4ee43c319c92ffcaf5ebb85412297f4144c3c7db7bf
DIST qt-creator-opensource-src-4.15.1.tar.xz 44655240 BLAKE2B 80d4b4688702f490ee478fa3efc34d72fcc586f27a480e310a3fbc5e2a5938cf61053ca87522884da2f4c2560f735a228f0fb24a63887a41fe5d21ff69f6344a SHA512 a735e2c14a4e9ca94ae209039017747f51320b465fdcf9d63e62bdf4d63d5099c6b114fa14af8869acf9290fba57be6bb756dcf78edcc6f3ac620c9e844241a3
diff --git a/dev-qt/qt-creator/files/qt-creator-4.12.0-dylib-fix.patch b/dev-qt/qt-creator/files/qt-creator-4.12.0-dylib-fix.patch
deleted file mode 100644
index 0d4deb2c7956..000000000000
--- a/dev-qt/qt-creator/files/qt-creator-4.12.0-dylib-fix.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-From 1c5faa6dcf16135ee31252d13766d01536a69405 Mon Sep 17 00:00:00 2001
-From: Peter Levine <plevine457@gmail.com>
-Date: Tue, 5 May 2020 03:45:35 -0400
-Subject: [PATCH] Fix building against clang configured with
- CLANG_LINK_CLANG_DYLIB
-
-LLVM/Clang upstream only officially supports building shared
-components as a single dynamic library (via
-LLVM_BUILD_LLVM_DYLIB=ON, CLANG_LINK_CLANG_DYLIB=ON, etc..).
-Linux distros like Fedora and Gentoo have followed suit.
-
-Unfortunately, QT-Creator's src/shared/clang/clang_installation.pri
-file assumes clang is built with separate component libraries
-and the build fails.
-
-This change alters the build to check for the existence
-of clang component libraries and, if found, link to them, or
-otherwise to libclang-cpp.
-
-Task-number: QTCREATORBUG-23172
-Change-Id: I17df5822d7aeb471227f21f2cf4a71871d6f9b86
----
- src/shared/clang/clang_installation.pri | 35 +++++++++++++++----------
- 1 file changed, 21 insertions(+), 14 deletions(-)
-
-diff --git a/src/shared/clang/clang_installation.pri b/src/shared/clang/clang_installation.pri
-index 08838838bca..c191c57f1c7 100644
---- a/src/shared/clang/clang_installation.pri
-+++ b/src/shared/clang/clang_installation.pri
-@@ -204,19 +204,6 @@ isEmpty(LLVM_VERSION) {
- }
- }
-
-- isEmpty(QTC_CLANG_BUILDMODE_MISMATCH)|!equals(QTC_CLANG_BUILDMODE_MISMATCH, 1) {
-- CLANGFORMAT_MAIN_HEADER = $$LLVM_INCLUDEPATH/clang/Format/Format.h
-- exists($$CLANGFORMAT_MAIN_HEADER) {
-- CLANGFORMAT_LIBS=-lclangFormat -lclangToolingInclusions -lclangToolingCore -lclangRewrite -lclangLex -lclangBasic
-- ALL_CLANG_LIBS=-lclangFormat -lclangToolingInclusions -lclangTooling -lclangToolingCore \
-- -lclangRewrite -lclangIndex -lclangFrontend -lclangParse -lclangSerialization \
-- -lclangSema -lclangEdit -lclangAnalysis -lclangDriver -lclangDynamicASTMatchers \
-- -lclangASTMatchers -lclangAST -lclangLex -lclangBasic
-- win32:CLANGFORMAT_LIBS += -lversion
-- }
-- }
-- win32:ALL_CLANG_LIBS += -lversion
--
- LIBCLANG_MAIN_HEADER = $$LLVM_INCLUDEPATH/clang-c/Index.h
- !exists($$LIBCLANG_MAIN_HEADER) {
- $$llvmWarningOrError(\
-@@ -237,10 +224,30 @@ isEmpty(LLVM_VERSION) {
- LIBCLANG_LIBS += $${CLANG_LIB}
-
- isEmpty(QTC_CLANG_BUILDMODE_MISMATCH)|!equals(QTC_CLANG_BUILDMODE_MISMATCH, 1) {
-+ CLANGFORMAT_MAIN_HEADER = $$LLVM_INCLUDEPATH/clang/Format/Format.h
-+ exists($$CLANGFORMAT_MAIN_HEADER) {
-+ exists($${LLVM_LIBDIR}/libclangFormat.so*)|exists($${LLVM_LIBDIR}/libclangFormat.dylib) {
-+ CLANGFORMAT_LIBS=-lclangFormat -lclangToolingInclusions -lclangToolingCore -lclangRewrite -lclangLex -lclangBasic
-+ ALL_CLANG_LIBS=-lclangFormat -lclangToolingInclusions -lclangTooling -lclangToolingCore \
-+ -lclangRewrite -lclangIndex -lclangFrontend -lclangParse -lclangSerialization \
-+ -lclangSema -lclangEdit -lclangAnalysis -lclangDriver -lclangDynamicASTMatchers \
-+ -lclangASTMatchers -lclangAST -lclangLex -lclangBasic
-+ win32:CLANGFORMAT_LIBS += -lversion
-+ win32:ALL_CLANG_LIBS += -lversion
-+ } else {
-+ CLANGFORMAT_LIBS=-lclang-cpp
-+ ALL_CLANG_LIBS=-lclang-cpp
-+ }
-+ }
-+
- QTC_DISABLE_CLANG_REFACTORING=$$(QTC_DISABLE_CLANG_REFACTORING)
- isEmpty(QTC_DISABLE_CLANG_REFACTORING) {
- !contains(QMAKE_DEFAULT_LIBDIRS, $$LLVM_LIBDIR): LIBTOOLING_LIBS = -L$${LLVM_LIBDIR}
-- LIBTOOLING_LIBS += $$CLANGTOOLING_LIBS $$LLVM_STATIC_LIBS
-+ exists($${LLVM_LIBDIR}/libclangTooling.so*)|exists($${LLVM_LIBDIR}/libclangTooling.dylib) {
-+ LIBTOOLING_LIBS += $$CLANGTOOLING_LIBS $$LLVM_STATIC_LIBS
-+ } else {
-+ LIBTOOLING_LIBS += -lclang-cpp $$LLVM_STATIC_LIBS
-+ }
- }
- }
-
---
-2.26.2
-
diff --git a/dev-qt/qt-creator/files/qt-creator-4.12.0-libclangformat-ide.patch b/dev-qt/qt-creator/files/qt-creator-4.12.0-libclangformat-ide.patch
deleted file mode 100644
index 12c46c89ed0e..000000000000
--- a/dev-qt/qt-creator/files/qt-creator-4.12.0-libclangformat-ide.patch
+++ /dev/null
@@ -1,64 +0,0 @@
---- a/src/plugins/clangformat/clangformatbaseindenter.h
-+++ b/src/plugins/clangformat/clangformatbaseindenter.h
-@@ -27,7 +27,7 @@
-
- #include <texteditor/indenter.h>
-
--#include <clang/Format/Format.h>
-+#include <clang/Format/FormatIDE.h>
-
- namespace ClangFormat {
-
---- a/src/plugins/clangformat/clangformatconfigwidget.cpp
-+++ b/src/plugins/clangformat/clangformatconfigwidget.cpp
-@@ -32,7 +32,7 @@
- #include "ui_clangformatchecks.h"
- #include "ui_clangformatconfigwidget.h"
-
--#include <clang/Format/Format.h>
-+#include <clang/Format/FormatIDE.h>
-
- #include <coreplugin/icore.h>
- #include <cppeditor/cpphighlighter.h>
---- a/src/plugins/clangformat/clangformatplugin.cpp
-+++ b/src/plugins/clangformat/clangformatplugin.cpp
-@@ -56,7 +56,7 @@
- #include <texteditor/icodestylepreferences.h>
- #include <texteditor/texteditorsettings.h>
-
--#include <clang/Format/Format.h>
-+#include <clang/Format/FormatIDE.h>
-
- #include <utils/algorithm.h>
-
---- a/src/plugins/clangformat/clangformatutils.h
-+++ b/src/plugins/clangformat/clangformatutils.h
-@@ -27,7 +27,7 @@
-
- #include <coreplugin/id.h>
- #include <utils/fileutils.h>
--#include <clang/Format/Format.h>
-+#include <clang/Format/FormatIDE.h>
-
- #include <QFile>
-
---- a/src/shared/clang/clang_installation.pri
-+++ b/src/shared/clang/clang_installation.pri
-@@ -227,7 +227,7 @@
- CLANGFORMAT_MAIN_HEADER = $$LLVM_INCLUDEPATH/clang/Format/Format.h
- exists($$CLANGFORMAT_MAIN_HEADER) {
- exists($${LLVM_LIBDIR}/libclangFormat.so*)|exists($${LLVM_LIBDIR}/libclangFormat.dylib) {
-- CLANGFORMAT_LIBS=-lclangFormat -lclangToolingInclusions -lclangToolingCore -lclangRewrite -lclangLex -lclangBasic
-+ CLANGFORMAT_LIBS=-lclangFormatIDE -lclangToolingInclusions -lclangToolingCore -lclangRewrite -lclangLex -lclangBasic
- ALL_CLANG_LIBS=-lclangFormat -lclangToolingInclusions -lclangTooling -lclangToolingCore \
- -lclangRewrite -lclangIndex -lclangFrontend -lclangParse -lclangSerialization \
- -lclangSema -lclangEdit -lclangAnalysis -lclangDriver -lclangDynamicASTMatchers \
-@@ -235,7 +235,7 @@
- win32:CLANGFORMAT_LIBS += -lversion
- win32:ALL_CLANG_LIBS += -lversion
- } else {
-- CLANGFORMAT_LIBS=-lclang-cpp
-+ CLANGFORMAT_LIBS=-lclangFormatIDE -lclang-cpp
- ALL_CLANG_LIBS=-lclang-cpp
- }
- }
diff --git a/dev-qt/qt-creator/metadata.xml b/dev-qt/qt-creator/metadata.xml
index f1b1bb3d0251..c9357db9d2db 100644
--- a/dev-qt/qt-creator/metadata.xml
+++ b/dev-qt/qt-creator/metadata.xml
@@ -25,7 +25,6 @@
<flag name="designer">Enable designer for QtWidgets-based UIs</flag>
<flag name="glsl">Build the GLSL editor plugin</flag>
<flag name="help">Enable the integrated documentation viewer</flag>
- <flag name="ios">Build plugin for Apple iOS devices</flag>
<flag name="lsp">Add support for the Language Server Protocol (LSP)</flag>
<flag name="mcu">Build plugin for MCU devices</flag>
<flag name="mercurial">Add support for <pkg>dev-vcs/mercurial</pkg> version control system</flag>
@@ -47,7 +46,6 @@
<flag name="valgrind">Enable integration with <pkg>dev-util/valgrind</pkg></flag>
<flag name="webassembly">Build WebAssembly plugin</flag>
<flag name="webengine">Use <pkg>dev-qt/qtwebengine</pkg> to view documentation</flag>
- <flag name="winrt">Build plugin for WinRT devices</flag>
</use>
<upstream>
<bugs-to>https://bugreports.qt.io/</bugs-to>
diff --git a/dev-qt/qt-creator/qt-creator-4.12.3-r1.ebuild b/dev-qt/qt-creator/qt-creator-4.12.3-r1.ebuild
deleted file mode 100644
index 5e676fcc1ce9..000000000000
--- a/dev-qt/qt-creator/qt-creator-4.12.3-r1.ebuild
+++ /dev/null
@@ -1,235 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-LLVM_MAX_SLOT=10
-PLOCALES="cs da de fr ja pl ru sl uk zh-CN zh-TW"
-
-inherit llvm qmake-utils virtualx xdg
-
-DESCRIPTION="Lightweight IDE for C++/QML development centering around Qt"
-HOMEPAGE="https://doc.qt.io/qtcreator/"
-LICENSE="GPL-3"
-SLOT="0"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://code.qt.io/${PN}/${PN}.git"
-else
- MY_PV=${PV/_/-}
- MY_P=${PN}-opensource-src-${MY_PV}
- [[ ${MY_PV} == ${PV} ]] && MY_REL=official || MY_REL=development
- SRC_URI="https://download.qt.io/${MY_REL}_releases/${PN/-}/$(ver_cut 1-2)/${MY_PV}/${MY_P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~x86"
- S=${WORKDIR}/${MY_P}
-fi
-
-# TODO: unbundle sqlite
-
-QTC_PLUGINS=(android +autotest baremetal beautifier boot2qt
- '+clang:clangcodemodel|clangformat|clangpchmanager|clangrefactoring|clangtools' clearcase
- cmake:cmakeprojectmanager cppcheck ctfvisualizer cvs +designer git glsl:glsleditor +help ios
- lsp:languageclient mcu:mcusupport mercurial modeling:modeleditor nim perforce perfprofiler python
- qbs:qbsprojectmanager +qmldesigner qmlprofiler qnx remotelinux scxml:scxmleditor serialterminal
- silversearcher subversion valgrind webassembly winrt)
-IUSE="doc systemd test +webengine ${QTC_PLUGINS[@]%:*}"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="
- boot2qt? ( remotelinux )
- clang? ( test? ( qbs ) )
- mcu? ( cmake )
- python? ( lsp )
- qnx? ( remotelinux )
-"
-
-# minimum Qt version required
-QT_PV="5.12.3:5"
-
-BDEPEND="
- >=dev-qt/linguist-tools-${QT_PV}
- virtual/pkgconfig
- doc? ( >=dev-qt/qdoc-${QT_PV} )
-"
-CDEPEND="
- >=dev-cpp/yaml-cpp-0.6.2:=
- >=dev-qt/qtconcurrent-${QT_PV}
- >=dev-qt/qtcore-${QT_PV}
- >=dev-qt/qtdeclarative-${QT_PV}[widgets]
- >=dev-qt/qtgui-${QT_PV}
- >=dev-qt/qtnetwork-${QT_PV}[ssl]
- >=dev-qt/qtprintsupport-${QT_PV}
- >=dev-qt/qtquickcontrols-${QT_PV}
- >=dev-qt/qtscript-${QT_PV}
- >=dev-qt/qtsql-${QT_PV}[sqlite]
- >=dev-qt/qtsvg-${QT_PV}
- >=dev-qt/qtwidgets-${QT_PV}
- >=dev-qt/qtx11extras-${QT_PV}
- >=dev-qt/qtxml-${QT_PV}
- kde-frameworks/syntax-highlighting:5
- clang? (
- || (
- ( sys-devel/clang:10
- dev-libs/libclangformat-ide:10 )
- ( sys-devel/clang:9
- dev-libs/libclangformat-ide:9 )
- )
- <sys-devel/clang-$((LLVM_MAX_SLOT + 1)):=
- )
- designer? ( >=dev-qt/designer-${QT_PV} )
- help? (
- >=dev-qt/qthelp-${QT_PV}
- webengine? ( >=dev-qt/qtwebengine-${QT_PV}[widgets] )
- )
- perfprofiler? ( dev-libs/elfutils )
- qbs? ( >=dev-util/qbs-1.13.1 )
- serialterminal? ( >=dev-qt/qtserialport-${QT_PV} )
- systemd? ( sys-apps/systemd:= )
-"
-DEPEND="${CDEPEND}
- test? (
- >=dev-qt/qtdeclarative-${QT_PV}[localstorage]
- >=dev-qt/qtquickcontrols2-${QT_PV}
- >=dev-qt/qttest-${QT_PV}
- >=dev-qt/qtxmlpatterns-${QT_PV}[qml]
- )
-"
-RDEPEND="${CDEPEND}
- sys-devel/gdb[python]
- cmake? ( dev-util/cmake )
- cppcheck? ( dev-util/cppcheck )
- cvs? ( dev-vcs/cvs )
- git? ( dev-vcs/git )
- mercurial? ( dev-vcs/mercurial )
- qmldesigner? ( >=dev-qt/qtquicktimeline-${QT_PV} )
- silversearcher? ( sys-apps/the_silver_searcher )
- subversion? ( dev-vcs/subversion )
- valgrind? ( dev-util/valgrind )
-"
-# qt translations must also be installed or qt-creator translations won't be loaded
-for x in ${PLOCALES}; do
- IUSE+=" l10n_${x}"
- RDEPEND+=" l10n_${x}? ( >=dev-qt/qttranslations-${QT_PV} )"
-done
-unset x
-
-PATCHES=(
- "${FILESDIR}"/${PN}-4.12.0-dylib-fix.patch
- "${FILESDIR}"/${PN}-4.12.0-libclangformat-ide.patch
-)
-
-llvm_check_deps() {
- has_version -d "sys-devel/clang:${LLVM_SLOT}" && \
- has_version -d "dev-libs/libclangformat-ide:${LLVM_SLOT}"
-}
-
-pkg_setup() {
- use clang && llvm_pkg_setup
-}
-
-src_prepare() {
- default
-
- # disable unwanted plugins
- for plugin in "${QTC_PLUGINS[@]#[+-]}"; do
- if ! use ${plugin%:*}; then
- einfo "Disabling ${plugin%:*} plugin"
- sed -i -re "s/(^\s+|\s*SUBDIRS\s*\+=.*)\<(${plugin#*:})\>(.*)/\1\3/" \
- src/plugins/plugins.pro || die "failed to disable ${plugin%:*} plugin"
- fi
- done
- sed -i -e '/updateinfo/d' src/plugins/plugins.pro || die
-
- # avoid building unused support libraries and tools
- if ! use clang; then
- sed -i -e '/clangsupport/d' src/libs/libs.pro || die
- sed -i -e '/clang\(\|pchmanager\|refactoring\)backend/d' src/tools/tools.pro || die
- fi
- if ! use glsl; then
- sed -i -e '/glsl/d' src/libs/libs.pro || die
- fi
- if ! use lsp; then
- sed -i -e '/languageserverprotocol/d' src/libs/libs.pro tests/auto/auto.pro || die
- fi
- if ! use modeling; then
- sed -i -e '/modelinglib/d' src/libs/libs.pro || die
- fi
- if ! use perfprofiler; then
- rm -r src/tools/perfparser || die
- if ! use ctfvisualizer && ! use qmlprofiler; then
- sed -i -e '/tracing/d' src/libs/libs.pro tests/auto/auto.pro || die
- fi
- fi
- if ! use qmldesigner; then
- sed -i -e '/qml2puppet/d' src/tools/tools.pro || die
- sed -i -e '/qmldesigner/d' tests/auto/qml/qml.pro || die
- fi
- if ! use valgrind; then
- sed -i -e '/valgrindfake/d' src/tools/tools.pro || die
- sed -i -e '/valgrind/d' tests/auto/auto.pro || die
- fi
-
- # automagic dep on qtwebengine
- if ! use webengine; then
- sed -i -e 's/isEmpty(QT\.webenginewidgets\.name)/true/' src/plugins/help/help.pro || die
- fi
-
- # disable broken or unreliable tests
- sed -i -e 's/\(manual\|tools\|unit\)//g' tests/tests.pro || die
- sed -i -e '/\(dumpers\|namedemangler\)\.pro/d' tests/auto/debugger/debugger.pro || die
- sed -i -e '/CONFIG -=/s/$/ testcase/' tests/auto/extensionsystem/pluginmanager/correctplugins1/plugin?/plugin?.pro || die
- sed -i -e 's/\<check\>//' tests/auto/qml/codemodel/codemodel.pro || die
-
- # do not install test binaries
- sed -i -e '/CONFIG +=/s/$/ no_testcase_installs/' tests/auto/{qttest.pri,json/json.pro} || die
-
- # fix path to some clang headers
- sed -i -e "/^CLANG_RESOURCE_DIR\s*=/s:\$\${LLVM_LIBDIR}:${EPREFIX}/usr/lib:" src/shared/clang/clang_defines.pri || die
-
- # fix translations
- local lang languages=
- for lang in ${PLOCALES}; do
- use l10n_${lang} && languages+=" ${lang/-/_}"
- done
- sed -i -e "/^LANGUAGES\s*=/s:=.*:=${languages}:" share/qtcreator/translations/translations.pro || die
-
- # remove bundled syntax-highlighting
- rm -r src/libs/3rdparty/syntax-highlighting || die
-
- # remove bundled yaml-cpp
- rm -r src/libs/3rdparty/yaml-cpp || die
-
- # remove bundled qbs
- rm -r src/shared/qbs || die
-}
-
-src_configure() {
- eqmake5 IDE_LIBRARY_BASENAME="$(get_libdir)" \
- IDE_PACKAGE_MODE=1 \
- KSYNTAXHIGHLIGHTING_LIB_DIR="${EPREFIX}/usr/$(get_libdir)" \
- KSYNTAXHIGHLIGHTING_INCLUDE_DIR="${EPREFIX}/usr/include/KF5/KSyntaxHighlighting" \
- $(use clang && echo LLVM_INSTALL_DIR="$(get_llvm_prefix ${LLVM_MAX_SLOT})") \
- $(use qbs && echo QBS_INSTALL_DIR="${EPREFIX}/usr") \
- CONFIG+=qbs_disable_rpath \
- CONFIG+=qbs_enable_project_file_updates \
- $(use systemd && echo CONFIG+=journald) \
- $(use test && echo BUILD_TESTS=1)
-}
-
-src_test() {
- cd tests/auto && virtx default
-}
-
-src_install() {
- emake INSTALL_ROOT="${ED}/usr" install
-
- dodoc dist/{changes-*,known-issues}
-
- # install documentation
- if use doc; then
- emake docs
- # don't use ${PF} or the doc will not be found
- insinto /usr/share/doc/qtcreator
- doins share/doc/qtcreator/qtcreator{,-dev}.qch
- docompress -x /usr/share/doc/qtcreator/qtcreator{,-dev}.qch
- fi
-}