summaryrefslogtreecommitdiff
path: root/dev-qt
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-09-13 09:42:24 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-13 12:40:19 -0400
commit67e0030c162d2705133385b5829486588bd6b8df (patch)
tree36c7bc8dbf10813d38671e480bfadf37597719fa /dev-qt
parentdev-qt/qttools: add IUSE=zstd to 6.6+ (diff)
downloadgentoo-67e0030c162d2705133385b5829486588bd6b8df.tar.gz
gentoo-67e0030c162d2705133385b5829486588bd6b8df.tar.bz2
gentoo-67e0030c162d2705133385b5829486588bd6b8df.zip
dev-qt/qttools: update qdoc handling in 6.6+
Did suspect that qdoc would become its own option eventually. It now also requires qml and clangcpp (on top of clang), not that we really need to pass clangcpp feature given it does no test and just mirrors the clang feature. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt')
-rw-r--r--dev-qt/qttools/qttools-6.6.9999.ebuild6
-rw-r--r--dev-qt/qttools/qttools-6.9999.ebuild6
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-qt/qttools/qttools-6.6.9999.ebuild b/dev-qt/qttools/qttools-6.6.9999.ebuild
index 490a140a2905..0e1eba0054cc 100644
--- a/dev-qt/qttools/qttools-6.6.9999.ebuild
+++ b/dev-qt/qttools/qttools-6.6.9999.ebuild
@@ -23,7 +23,7 @@ REQUIRED_USE="
designer? ( qml widgets )
distancefieldgenerator? ( qml widgets )
pixeltool? ( widgets )
- qdoc? ( clang )
+ qdoc? ( clang qml )
"
# behaves very badly when qttools is not already installed, also
@@ -61,13 +61,13 @@ src_configure() {
$(cmake_use_find_package qml Qt6Qml)
$(cmake_use_find_package widgets Qt6Widgets)
$(qt_feature assistant)
- $(qt_feature clang clangcpp)
+ $(qt_feature clang)
$(qt_feature designer)
$(qt_feature distancefieldgenerator)
$(qt_feature linguist)
$(qt_feature pixeltool)
$(qt_feature qdbus)
- $(qt_feature qdoc clang)
+ $(qt_feature qdoc)
$(qt_feature qtattributionsscanner)
$(qt_feature qtdiag)
$(qt_feature qtplugininfo)
diff --git a/dev-qt/qttools/qttools-6.9999.ebuild b/dev-qt/qttools/qttools-6.9999.ebuild
index 490a140a2905..0e1eba0054cc 100644
--- a/dev-qt/qttools/qttools-6.9999.ebuild
+++ b/dev-qt/qttools/qttools-6.9999.ebuild
@@ -23,7 +23,7 @@ REQUIRED_USE="
designer? ( qml widgets )
distancefieldgenerator? ( qml widgets )
pixeltool? ( widgets )
- qdoc? ( clang )
+ qdoc? ( clang qml )
"
# behaves very badly when qttools is not already installed, also
@@ -61,13 +61,13 @@ src_configure() {
$(cmake_use_find_package qml Qt6Qml)
$(cmake_use_find_package widgets Qt6Widgets)
$(qt_feature assistant)
- $(qt_feature clang clangcpp)
+ $(qt_feature clang)
$(qt_feature designer)
$(qt_feature distancefieldgenerator)
$(qt_feature linguist)
$(qt_feature pixeltool)
$(qt_feature qdbus)
- $(qt_feature qdoc clang)
+ $(qt_feature qdoc)
$(qt_feature qtattributionsscanner)
$(qt_feature qtdiag)
$(qt_feature qtplugininfo)