summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-13 18:50:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-13 18:50:45 +0200
commitf8b68cbe7c388bbfcf5134eefbca162c914f57dc (patch)
treeeb3ee941eca011b9f62e13971cd04e97b59ece99 /dev-qt/qtwayland
parentmedia-libs/mesa: Support unconditional enabling of drivers (diff)
downloadgentoo-f8b68cbe7c388bbfcf5134eefbca162c914f57dc.tar.gz
gentoo-f8b68cbe7c388bbfcf5134eefbca162c914f57dc.tar.bz2
gentoo-f8b68cbe7c388bbfcf5134eefbca162c914f57dc.zip
dev-qt: Add Qt 5.9.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.9.6.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 2933fd9f3538..7332db404110 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,3 +1,4 @@
DIST qtwayland-everywhere-src-5.11.0-rc2.tar.xz 391416 BLAKE2B 1cc160350430add0129a5976e78bf0d484d9c02d350859f52c93f09c79056d66c623f15c01e348722caa3aadf9e1fe843c5823415f6c6f405764ba7895b7adfa SHA512 0b2857cbfcc1da8ae7cdf5066d9c4d79c6d3e3768afc4f290eb8cf64260655451fdf4e1e67889d414fb651686bd60d4a5df3d890921eb13d0079760bffb94d3a
DIST qtwayland-opensource-src-5.9.4.tar.xz 314932 BLAKE2B de90fb47af0d07e0b6476b84de2f51900e4e09ecd57aee800534998d3a2e733501da877f912c4b0ce671d417f543eb44bc1607225af0a134ba5702d17efae431 SHA512 93d43bdcc39fd471cdd335c0699c5e5dd77cd0bc2d15f2a1170d8ccd103d84e2c7e657575a370ac6c678b52c2b617fb2c80ce4d226264cb6c857064452f7dc10
DIST qtwayland-opensource-src-5.9.5.tar.xz 316056 BLAKE2B bd270a3c2a87874e533f8ec772b6435834f2eca1130d4efccd3543cd1170064950020e62910f6e80e6be1bcc20133a240ac9d89a9afe86db4e267c1718bccaf2 SHA512 31b8c8fb0c1e7172006053fc1added67a4312aec364b0d762bd9ff5fd451b298cdf34a47dc043af8e5212f856f79efd32014ac4c35e0ff7661d83e19c6fd1289
+DIST qtwayland-opensource-src-5.9.6.tar.xz 316152 BLAKE2B a1ebbf98eea9ca36f8229ed0bdfdeb79eb9d1519ff35eb153d7f8b7af2ad9831905e564464ec1faf793a7b11088d43d6dda6dc21b36943fccb569163c119a30a SHA512 7376f76001323d7971cb3be7592086b26c855d8d702184e84f28656b4262a9780b4cc0a0991c97ca011863570b6abd63b006c78021934e1516be65715f82ae4b
diff --git a/dev-qt/qtwayland/qtwayland-5.9.6.ebuild b/dev-qt/qtwayland/qtwayland-5.9.6.ebuild
new file mode 100644
index 000000000000..4c3553046dbc
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.9.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="+libinput xcomposite"
+
+DEPEND="
+ >=dev-libs/wayland-1.6.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}[egl,libinput?]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ xcomposite? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_config libinput xkbcommon-evdev \
+ src/client/client.pro \
+ src/compositor/wayland_wrapper/wayland_wrapper.pri \
+ src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
+ tests/auto/compositor/compositor/compositor.pro
+
+ use xcomposite || rm -r config.tests/xcomposite || die
+
+ qt5-build_src_prepare
+}