summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-13 20:02:39 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-13 20:08:37 +0200
commit5ecb8e6a436e4c574f0ceef868c7369275f82b18 (patch)
tree8c0692e3eda6b128e54f74e3e7fc2184f2c76018 /dev-qt/qtwayland
parentdev-python/paho-mqtt: bump version to 1.3.1 (diff)
downloadgentoo-5ecb8e6a436e4c574f0ceef868c7369275f82b18.tar.gz
gentoo-5ecb8e6a436e4c574f0ceef868c7369275f82b18.tar.bz2
gentoo-5ecb8e6a436e4c574f0ceef868c7369275f82b18.zip
dev-qt: 5.9.5 version bump
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/Manifest1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.9.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-qt/qtwayland/Manifest b/dev-qt/qtwayland/Manifest
index 6cdadacb0812..ebf1a8d874f2 100644
--- a/dev-qt/qtwayland/Manifest
+++ b/dev-qt/qtwayland/Manifest
@@ -1,2 +1,3 @@
DIST qtwayland-opensource-src-5.7.1.tar.xz 291776 BLAKE2B 06aba415e33ed971ef4de975e8677a52c4fcc81922f978cc1bde7e9a7ebdea32cd1c7dca59b67493bc96edfd997027f630c05c93ce31ae4ba87a55580495997a SHA512 41a6699b9048a859bb0cb1e37cd0a3977f52a5a223d4f6a4ce5e1402c5b829cc907593ce2b70f4ec24dfad147251bb2f20e889eae26072cf53e774b4585f2921
DIST qtwayland-opensource-src-5.9.4.tar.xz 314932 BLAKE2B de90fb47af0d07e0b6476b84de2f51900e4e09ecd57aee800534998d3a2e733501da877f912c4b0ce671d417f543eb44bc1607225af0a134ba5702d17efae431 SHA512 93d43bdcc39fd471cdd335c0699c5e5dd77cd0bc2d15f2a1170d8ccd103d84e2c7e657575a370ac6c678b52c2b617fb2c80ce4d226264cb6c857064452f7dc10
+DIST qtwayland-opensource-src-5.9.5.tar.xz 316056 BLAKE2B bd270a3c2a87874e533f8ec772b6435834f2eca1130d4efccd3543cd1170064950020e62910f6e80e6be1bcc20133a240ac9d89a9afe86db4e267c1718bccaf2 SHA512 31b8c8fb0c1e7172006053fc1added67a4312aec364b0d762bd9ff5fd451b298cdf34a47dc043af8e5212f856f79efd32014ac4c35e0ff7661d83e19c6fd1289
diff --git a/dev-qt/qtwayland/qtwayland-5.9.5.ebuild b/dev-qt/qtwayland/qtwayland-5.9.5.ebuild
new file mode 100644
index 000000000000..4c3553046dbc
--- /dev/null
+++ b/dev-qt/qtwayland/qtwayland-5.9.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="Wayland platform plugin for Qt"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+fi
+
+IUSE="+libinput xcomposite"
+
+DEPEND="
+ >=dev-libs/wayland-1.6.0
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+ ~dev-qt/qtgui-${PV}[egl,libinput?]
+ media-libs/mesa[egl]
+ >=x11-libs/libxkbcommon-0.2.0
+ xcomposite? (
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ qt_use_disable_config libinput xkbcommon-evdev \
+ src/client/client.pro \
+ src/compositor/wayland_wrapper/wayland_wrapper.pri \
+ src/plugins/shellintegration/ivi-shell/ivi-shell.pro \
+ tests/auto/compositor/compositor/compositor.pro
+
+ use xcomposite || rm -r config.tests/xcomposite || die
+
+ qt5-build_src_prepare
+}