summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-19 14:18:09 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-09-05 09:01:01 -0400
commit7c34d9a49348ceb4f2e4443220e8d1481c829c62 (patch)
treec419075baf7ef561ef80e04881a68ed2040f39e1 /dev-qt/qtimageformats
parentqt6-build.eclass: prevent passing -O2 after user's C(XX)FLAGS (diff)
downloadgentoo-7c34d9a49348ceb4f2e4443220e8d1481c829c62.tar.gz
gentoo-7c34d9a49348ceb4f2e4443220e8d1481c829c62.tar.bz2
gentoo-7c34d9a49348ceb4f2e4443220e8d1481c829c62.zip
dev-qt/*: import qt6 live ebuilds from ::qt
As-is, no changes in this commit which is mostly the same as the current in-tree ebuilds. Maintaining these in two different repos feels like just a hassle (to me), and would rather have everything in one place so I can change live and release ebuilds simultaneously as needed, plus not have to sync metadata or eclass changes either (plus chiitoo has ::gentoo commit access now). May move packages if I happen to work on them, albeit I have no intention to really touch Qt5 or LXQt (anyone working on these are free to the same if they want, or keep current workflow). Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-qt/qtimageformats')
-rw-r--r--dev-qt/qtimageformats/qtimageformats-6.5.9999.ebuild35
-rw-r--r--dev-qt/qtimageformats/qtimageformats-6.9999.ebuild35
2 files changed, 70 insertions, 0 deletions
diff --git a/dev-qt/qtimageformats/qtimageformats-6.5.9999.ebuild b/dev-qt/qtimageformats/qtimageformats-6.5.9999.ebuild
new file mode 100644
index 000000000000..ffa831e51aa5
--- /dev/null
+++ b/dev-qt/qtimageformats/qtimageformats-6.5.9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Additional format plugins for the Qt image I/O system"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="mng"
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*[gui]
+ media-libs/libwebp:=
+ media-libs/tiff:=
+ mng? ( media-libs/libmng:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT_FEATURE_jasper=OFF
+ $(qt_feature mng)
+ -DQT_FEATURE_tiff=ON
+ -DQT_FEATURE_webp=ON
+ -DQT_FEATURE_system_tiff=ON
+ -DQT_FEATURE_system_webp=ON
+ )
+
+ qt6-build_src_configure
+}
diff --git a/dev-qt/qtimageformats/qtimageformats-6.9999.ebuild b/dev-qt/qtimageformats/qtimageformats-6.9999.ebuild
new file mode 100644
index 000000000000..ffa831e51aa5
--- /dev/null
+++ b/dev-qt/qtimageformats/qtimageformats-6.9999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qt6-build
+
+DESCRIPTION="Additional format plugins for the Qt image I/O system"
+
+if [[ ${QT6_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64"
+fi
+
+IUSE="mng"
+
+DEPEND="
+ =dev-qt/qtbase-${PV}*[gui]
+ media-libs/libwebp:=
+ media-libs/tiff:=
+ mng? ( media-libs/libmng:= )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DQT_FEATURE_jasper=OFF
+ $(qt_feature mng)
+ -DQT_FEATURE_tiff=ON
+ -DQT_FEATURE_webp=ON
+ -DQT_FEATURE_system_tiff=ON
+ -DQT_FEATURE_system_webp=ON
+ )
+
+ qt6-build_src_configure
+}