summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-13 06:02:00 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-13 06:02:00 +0200
commitf82465ada5a0c77dfddfbc48680b4103d260634f (patch)
treeaf7bad5fb73c41656a051e86f84e23bf4ae18284 /dev-python
parentdev-python/sqlalchemy: Bump to 2.0.22 (diff)
downloadgentoo-f82465ada5a0c77dfddfbc48680b4103d260634f.tar.gz
gentoo-f82465ada5a0c77dfddfbc48680b4103d260634f.tar.bz2
gentoo-f82465ada5a0c77dfddfbc48680b4103d260634f.zip
dev-python/hypothesis: Bump to 6.87.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-6.87.4.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 46dfeb4ce879..1db5c8d6425a 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -2,3 +2,4 @@ DIST hypothesis-6.84.3.gh.tar.gz 9386113 BLAKE2B 9d990b1634e7cd12f933f3a53b4231f
DIST hypothesis-6.87.1.gh.tar.gz 9388383 BLAKE2B 0b0b9156566a84f4e5972960dbf5ec68c68703e0be0ac31392919a5177332f1dccfc7519c0a58ea2ed9f758f1b9d7e601b30e72db63c85031f5136b83c6dd255 SHA512 1f946d99ecbb3392b105ed479b43a72034d1563c541d1bdc263c76495b05e7e9881585cad50b6c0453e083b05e1ebd1c2ff0cf5a8b98f0f7ce68f009d23dbfeb
DIST hypothesis-6.87.2.gh.tar.gz 9388126 BLAKE2B c73c52b6f75b212bd9683e936edb4605aeebff7f7aad8bafdf4097a7793967b4d9fac78385e8fdec3f6fcea94c74cb624a8376ee2ec338a426075a80d70b2eb1 SHA512 2276d4ac43e29245b1c1d7cd810bc0bf97f4088c0900fcc5387465e8cd1d13648c0ae66a4c4632bf4affe9b03f5063092f805fea27ac533f33e14b14106dddfb
DIST hypothesis-6.87.3.gh.tar.gz 9388318 BLAKE2B 61dea9f0898cadef747871e2ef137ed8c68b1cfa43cc0b7a3effd6669b8dc7d8809f39af4f0a915831e3e2950280d132650d8d2193664a08c6f026f98db82330 SHA512 c7c0388c06e8d9397e8a9e6103525c5ea0f94017dad71f4547ff6b385f76f88e511b5f8a5b64f76c728379fbca8ad3b77e06b0d474d76f7f68c79fe1e087da91
+DIST hypothesis-6.87.4.gh.tar.gz 9388435 BLAKE2B a678bf1d76a1947f6880de95e3b418de364d5083a6c9c5ce8ff36fc51290ab7ed1560627e6aaf493c9b11184126ed5c2a6f8bcbd56633555cdb9be11dc384d1b SHA512 b4dcff9d07a665d7b134dfeaa6a7f199cc87883b9cd078d573a175b24069e968ce833bcdcf89f7665cf021a1eaf6df08eddc5dd071c4189ffe681ce3a178e432
diff --git a/dev-python/hypothesis/hypothesis-6.87.4.ebuild b/dev-python/hypothesis/hypothesis-6.87.4.ebuild
new file mode 100644
index 000000000000..0d6df2a9e475
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-6.87.4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+CLI_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( "${CLI_COMPAT[@]}" pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 multiprocessing optfeature
+
+TAG=hypothesis-python-${PV}
+MY_P=hypothesis-${TAG}
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="
+ https://github.com/HypothesisWorks/hypothesis/
+ https://pypi.org/project/hypothesis/
+"
+SRC_URI="
+ https://github.com/HypothesisWorks/hypothesis/archive/${TAG}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}/hypothesis-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="cli"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.0.0_rc8[${PYTHON_USEDEP}]
+ ' 3.9 3.10)
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' "${CLI_COMPAT[@]}")
+ )
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/requests-toolbelt-0.10.1
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ # subtests are broken by warnings from random plugins
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=xdist.plugin,pytest_forked,_hypothesis_pytestplugin
+ local -x HYPOTHESIS_NO_PLUGINS=1
+
+ # NB: paths need to be relative to pytest.ini,
+ # i.e. start with hypothesis-python/
+ local EPYTEST_DESELECT=()
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # failing due to warnings from numpy/cython
+ hypothesis-python/tests/pytest/test_fixtures.py::test_given_plus_overridden_fixture
+ )
+ ;;
+ esac
+
+ epytest -o filterwarnings= -n "$(makeopts_jobs)" --dist=worksteal \
+ tests/cover tests/pytest tests/quality
+}
+
+python_install() {
+ distutils-r1_python_install
+ if ! use cli || ! has "${EPYTHON}" "${CLI_COMPAT[@]/_/.}"; then
+ rm -r "${ED}/usr/bin" "${D}$(python_get_scriptdir)" || die
+ fi
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}