summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-17 04:46:58 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-17 04:46:58 +0200
commitf5d5a54270037b5461377c23c697c24bdaa80329 (patch)
tree2a1045329b08ad31e4216b3205ddcdfabce86b2d /dev-python
parentdev-python/trove-classifiers: Bump to 2024.10.16 (diff)
downloadgentoo-f5d5a54270037b5461377c23c697c24bdaa80329.tar.gz
gentoo-f5d5a54270037b5461377c23c697c24bdaa80329.tar.bz2
gentoo-f5d5a54270037b5461377c23c697c24bdaa80329.zip
dev-python/pbs-installer: Bump to 2024.10.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pbs-installer/Manifest1
-rw-r--r--dev-python/pbs-installer/pbs-installer-2024.10.16.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pbs-installer/Manifest b/dev-python/pbs-installer/Manifest
index d0044d88a2a0..1916cf97048d 100644
--- a/dev-python/pbs-installer/Manifest
+++ b/dev-python/pbs-installer/Manifest
@@ -1 +1,2 @@
+DIST pbs-installer-2024.10.16.gh.tar.gz 79499 BLAKE2B 749a0ecc54a4df1e5989eee54b874b92bd7592307fe9bc0a13aa77dea96dcec8b6ff7b5fcfd10e354eaad21054cbf264c718fa7d692c6ee2df348f9217ca89ca SHA512 1b6bfc64bf311d03cf318365b1d16968ac599b40b247970477d6555791407bc104813bd60f82e30d88a13cd37873fef269a98640ee301f86028e6ddf7d097958
DIST pbs-installer-2024.4.24.gh.tar.gz 73601 BLAKE2B f56483899dc7795d0334b4698e08f71799ede456fdb7f78accc9278f32437a6b785055ec0b61854c6ec05663bc3b4bd41be8d45138a5793dcab35aa80da32de8 SHA512 7bd440e1522a1c826dcfac801763ad256d79f60315a30828082ea65169e5f4cc8527866491a5c4d84d847150ed6f90167b550104031f417e0103640e2c291aeb
diff --git a/dev-python/pbs-installer/pbs-installer-2024.10.16.ebuild b/dev-python/pbs-installer/pbs-installer-2024.10.16.ebuild
new file mode 100644
index 000000000000..c2bbf1f95bc4
--- /dev/null
+++ b/dev-python/pbs-installer/pbs-installer-2024.10.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Installer for Python Build Standalone"
+HOMEPAGE="
+ https://pypi.org/project/pbs-installer/
+ https://github.com/frostming/pbs-installer/
+
+"
+SRC_URI="
+ https://github.com/frostming/pbs-installer/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+BDEPEND="
+ dev-python/zstandard[${PYTHON_USEDEP}]
+"
+
+# upstream does not provide any tests
+RESTRICT=test
+
+python_configure_all() {
+ export PDM_BUILD_SCM_VERSION=${PV}
+}