summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-10-28 23:28:30 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-10-28 23:28:42 +0200
commite363e427e8f7a291e8b1ec886682e5cb7d7c9ed6 (patch)
treefb183b338a9134f7a9c506578c64b688ed566ca9 /dev-python
parentdev-perl/IO-Socket-SSL: stable 2.48.0 for hppa, bug #632548 (thanks to Rolf E... (diff)
downloadgentoo-e363e427e8f7a291e8b1ec886682e5cb7d7c9ed6.tar.gz
gentoo-e363e427e8f7a291e8b1ec886682e5cb7d7c9ed6.tar.bz2
gentoo-e363e427e8f7a291e8b1ec886682e5cb7d7c9ed6.zip
dev-python/python-gnupg: version bump.
Closes: https://bugs.gentoo.org/622224 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/python-gnupg/Manifest1
-rw-r--r--dev-python/python-gnupg/python-gnupg-0.4.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/python-gnupg/Manifest b/dev-python/python-gnupg/Manifest
index 87f7c5e9c764..00e1e45c230b 100644
--- a/dev-python/python-gnupg/Manifest
+++ b/dev-python/python-gnupg/Manifest
@@ -1 +1,2 @@
DIST python-gnupg-0.3.8.tar.gz 38993 SHA256 3872ced77d69203f31817107b324b0dd33d4437a330dc58eca140c8758d26b5a SHA512 128ba1f89e8baf0d1ae53153d7cbe73bfc99617a1aadfd9a02e2e2e2c5f0bb9c7482023bf54f32989e92cc14a9eb32325e4c358c63bce48a70a78d068103ed4f WHIRLPOOL 9080ceeade7e4c614a532eccbd4e9818d62233a6d1751acb159e8e0f13c71edf177d2c1592f0685c7e4139ba59826b8cb13864c11c37e33445a176c693d84f52
+DIST python-gnupg-0.4.0.tar.gz 43987 SHA256 e6aaf344852fa11824e4151ab63326a07dd0ef977dddffcce43669a79842a8f9 SHA512 f486ec97aee01cf46d055421211ff5704093a382155043b7ced6f809dc15d7669d5869038a1b26c5f1831076d85c929d781bc22e35ab293a14bc6e2f5f27fa32 WHIRLPOOL cdb34fe95f147fab286d1bcf0574ed186a4557f6cd866a10a1a37076a218e586b4b66cdd3dba754acfc7cad140c583b93e3779986d3408b4148c84f89e8ca85a
diff --git a/dev-python/python-gnupg/python-gnupg-0.4.0.ebuild b/dev-python/python-gnupg/python-gnupg-0.4.0.ebuild
new file mode 100644
index 000000000000..72c13fabebbc
--- /dev/null
+++ b/dev-python/python-gnupg/python-gnupg-0.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for GNU Privacy Guard"
+HOMEPAGE="http://pythonhosted.org/python-gnupg/ https://github.com/vsajip/python-gnupg/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+
+RDEPEND="app-crypt/gnupg"
+DEPEND="${RDEPEND}"
+
+# They hung. We haven't figured out why yet.
+RESTRICT="test"
+
+python_test() {
+ # Note; 1 test fails under pypy only
+ "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
+}