summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-12 04:45:22 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-12 04:56:08 +0200
commitd423c877be7d40c3cf81c606c5122c685e1bcdff (patch)
tree84b1f301e497c75c3e1590fb72a9687d5e016cc3 /dev-python
parentdev-python/pydantic-core: Bump to 2.18.1 (diff)
downloadgentoo-d423c877be7d40c3cf81c606c5122c685e1bcdff.tar.gz
gentoo-d423c877be7d40c3cf81c606c5122c685e1bcdff.tar.bz2
gentoo-d423c877be7d40c3cf81c606c5122c685e1bcdff.zip
dev-python/pydantic: Bump to 2.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pydantic/Manifest1
-rw-r--r--dev-python/pydantic/pydantic-2.7.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/pydantic/Manifest b/dev-python/pydantic/Manifest
index e3f7a949155e..c7ce829be719 100644
--- a/dev-python/pydantic/Manifest
+++ b/dev-python/pydantic/Manifest
@@ -1,2 +1,3 @@
DIST pydantic-2.6.3.tar.gz 680427 BLAKE2B 28d8d4edcfeeae4f0ba70ed09987e26ba569c38b2c511b6d0b4277b830173302228c964f4c086ac4412a331afa3fba16d9581bd31446fb1dfb43065eb29dfc59 SHA512 2eca898328beb1f33e343d3aa7edf8847baae0569d078507a58bbe0fcf355250c72b70a33f6b79cef697f41ced91eaeee1ffc4a7712fd6fd251fd64557e390d0
DIST pydantic-2.6.4.tar.gz 680828 BLAKE2B 264698f21e4d57656f5a28651019956349a018f16b11099d4afd796329a8ad12847e45250372e5c7b189493e9c73efa624006cb2e6b5a7d77b2c45973a0d813f SHA512 9386c2e04ff71bc182be4892d1cdb910ca60ee68b7cc5c6e86a58529b51707094532dc5315bf152b147979bace3d2e4f6bb4fed546e16fe27b5ecd35c7d0541a
+DIST pydantic-2.7.0.tar.gz 710409 BLAKE2B 79b426edaa599dac99bb4d465690738be2fae5ffb6ba588491470d41d71fc8aecb4cf731457b00dc22911106c86d549ce11118bdc386dfba210cb5973b366aec SHA512 06254a99456a999dd5b165c032e3d5fb48a59d56beb51c1ff77d2dbf181bc2b535801307adf00f3547d5f60fd868ead8d6baf507564c52e09e1efe04c155aeb9
diff --git a/dev-python/pydantic/pydantic-2.7.0.ebuild b/dev-python/pydantic/pydantic-2.7.0.ebuild
new file mode 100644
index 000000000000..29b3c947ef29
--- /dev/null
+++ b/dev-python/pydantic/pydantic-2.7.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Data parsing and validation using Python type hints"
+HOMEPAGE="
+ https://github.com/pydantic/pydantic/
+ https://pypi.org/project/pydantic/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/annotated-types-0.4.0[${PYTHON_USEDEP}]
+ ~dev-python/pydantic-core-2.18.1[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.6.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/hatch-fancy-pypi-readme-22.5.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/dirty-equals[${PYTHON_USEDEP}]
+ >=dev-python/email-validator-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/Faker-18.13.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/benchmark/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=()
+ local EPYTEST_IGNORE=(
+ # require pytest-examples
+ tests/test_docs.py
+ # benchmarks
+ tests/benchmarks
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_mock
+}