summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-22 07:11:08 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-22 07:11:08 +0200
commitd3c61de2abbc25789f1efd43641ec37033861e41 (patch)
treecd07d22585ea79243067054cc6526cb2794c9834 /dev-python
parentdev-python/setuptools: Update RDEPEND for unbundled deps (diff)
downloadgentoo-d3c61de2abbc25789f1efd43641ec37033861e41.tar.gz
gentoo-d3c61de2abbc25789f1efd43641ec37033861e41.tar.bz2
gentoo-d3c61de2abbc25789f1efd43641ec37033861e41.zip
dev-python/sphinx: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx/Manifest1
-rw-r--r--dev-python/sphinx/sphinx-4.4.0-r1.ebuild123
2 files changed, 0 insertions, 124 deletions
diff --git a/dev-python/sphinx/Manifest b/dev-python/sphinx/Manifest
index 1292a42d7655..7184566ea1e6 100644
--- a/dev-python/sphinx/Manifest
+++ b/dev-python/sphinx/Manifest
@@ -1,2 +1 @@
-DIST Sphinx-4.4.0.tar.gz 6690021 BLAKE2B 5f63a6a70b8fb663ff1729766183f8936c9cd3bab81437526fb099ccc2a49c2abd42b602e2fc37af79254a9c8f1238fb4c99f2659142e9b9c2c1a2bd385ac100 SHA512 f5780a7da7a5d758b0e145ab9a7f191a9c65fd3ca4624ca3a04f0d161e3cd6c7133df53ff56e42f012687cbce0460178c2e7957974b5b929b341c98db996c640
DIST Sphinx-4.5.0.tar.gz 6698212 BLAKE2B e6c46d35492c3d3068c4f97e497d33973ca86b40934578804fcec901fa89d2c52b45a7546b835b873846dd16936c1bd34a7b053aec8206c688d974671155fd56 SHA512 b44d2a81ed67adaefe16a07ae0cf053b5e6c775023aaa6c57d7b3950f171deac410e8004f787b151c3c2fc350650aa69a4dc2dc7239d1fd3d351e5194617cb2c
diff --git a/dev-python/sphinx/sphinx-4.4.0-r1.ebuild b/dev-python/sphinx/sphinx-4.4.0-r1.ebuild
deleted file mode 100644
index 43a0b572068c..000000000000
--- a/dev-python/sphinx/sphinx-4.4.0-r1.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Python documentation generator"
-HOMEPAGE="https://www.sphinx-doc.org/
- https://github.com/sphinx-doc/sphinx"
-SRC_URI="mirror://pypi/S/${PN^}/${P^}.tar.gz"
-S=${WORKDIR}/${P^}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="doc latex"
-
-RDEPEND="
- <dev-python/alabaster-0.8[${PYTHON_USEDEP}]
- >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
- <dev-python/docutils-0.18[${PYTHON_USEDEP}]
- dev-python/imagesize[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.3[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/snowballstemmer-1.1[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-applehelp[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-devhelp[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-jsmath[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-htmlhelp-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/sphinxcontrib-serializinghtml-1.1.5[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-qthelp[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-4.4[${PYTHON_USEDEP}]
- ' python3_{8,9} pypy3)
- latex? (
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-luatex
- app-text/dvipng
- )
- !dev-python/namespace-sphinxcontrib
-"
-BDEPEND="
- doc? (
- dev-python/sphinxcontrib-websupport[${PYTHON_USEDEP}]
- media-gfx/graphviz
- )
- test? (
- dev-python/html5lib[${PYTHON_USEDEP}]
- virtual/imagemagick-tools[jpeg,png,svg]
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-latexextra
- dev-texlive/texlive-luatex
- app-text/dvipng
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-3.2.1-doc-link.patch"
- "${FILESDIR}/${PN}-4.3.2-doc-link.patch"
-)
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # disable internet access
- sed -i -e 's:^intersphinx_mapping:disabled_&:' \
- doc/conf.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- esetup.py build_sphinx
- HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- fi
-}
-
-python_test() {
- mkdir -p "${BUILD_DIR}/sphinx_tempdir" || die
- local -x SPHINX_TEST_TEMPDIR="${BUILD_DIR}/sphinx_tempdir"
-
- local EPYTEST_DESELECT=(
- # these tests require Internet access
- tests/test_build_latex.py::test_latex_images
- tests/test_build_linkcheck.py::test_defaults
- tests/test_build_linkcheck.py::test_defaults_json
- tests/test_build_linkcheck.py::test_anchors_ignored
- tests/test_build_linkcheck.py::test_linkcheck_exclude_documents
- # TODO
- tests/test_ext_autodoc_autoclass.py::test_classes
- tests/test_ext_autodoc_autofunction.py::test_classes
- )
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- tests/test_build_linkcheck.py::test_connect_to_selfsigned_fails
- tests/test_ext_autodoc.py::test_autodoc_inherited_members_None
- tests/test_ext_autodoc.py::test_autodoc_typed_inherited_instance_variables
- tests/test_ext_autodoc.py::test_autodoc_typed_instance_variables
- tests/test_ext_autodoc.py::test_automethod_for_builtin
- tests/test_ext_autodoc.py::test_cython
- tests/test_ext_autodoc.py::test_partialfunction
- tests/test_ext_autodoc_autoclass.py::test_autodoc_process_bases
- tests/test_ext_autodoc_autoclass.py::test_show_inheritance_for_decendants_of_generic_type
- tests/test_ext_autodoc_autoclass.py::test_show_inheritance_for_subclass_of_generic_type
- tests/test_ext_autodoc_autodata.py::test_autodata_type_comment
- tests/test_ext_autodoc_autofunction.py::test_builtin_function
- tests/test_ext_autodoc_autofunction.py::test_methoddescriptor
- tests/test_ext_autodoc_configs.py::test_autodoc_type_aliases
- tests/test_ext_autodoc_configs.py::test_autodoc_typehints_signature
- tests/test_ext_autosummary.py::test_autosummary_generate_content_for_module
- tests/test_ext_autosummary.py::test_autosummary_generate_content_for_module_skipped
- tests/test_pycode_parser.py::test_annotated_assignment
- )
-
- epytest
-}