summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-12-19 16:13:30 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-01-16 10:02:59 +0200
commitd05f1fdd0033aeb8e54ff3fd25536019c0ec3ccb (patch)
tree6ec77011238fbc94f220c101efb4fefeea356b94 /dev-python
parentdev-python/pyxDamerauLevenshtein: new dependency of spyder (diff)
downloadgentoo-d05f1fdd0033aeb8e54ff3fd25536019c0ec3ccb.tar.gz
gentoo-d05f1fdd0033aeb8e54ff3fd25536019c0ec3ccb.tar.bz2
gentoo-d05f1fdd0033aeb8e54ff3fd25536019c0ec3ccb.zip
dev-python/sphinxcontrib-bibtex: new dependency of spyder
Sphinx extensions for BibTeX style citations. Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinxcontrib-bibtex/Manifest1
-rw-r--r--dev-python/sphinxcontrib-bibtex/metadata.xml16
-rw-r--r--dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.0.0.ebuild31
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/sphinxcontrib-bibtex/Manifest b/dev-python/sphinxcontrib-bibtex/Manifest
new file mode 100644
index 000000000000..8a428f1c4b05
--- /dev/null
+++ b/dev-python/sphinxcontrib-bibtex/Manifest
@@ -0,0 +1 @@
+DIST sphinxcontrib-bibtex-2.0.0.tar.gz 135555 BLAKE2B 8a542ff7895a89a8dbf6b8ed1df3ab4e928b68ce86881819c1fbfafdda626c2e1106f5513832ee09248381c89f54f06d4d1b42f005b1f775b0fbe8962a0a0ff1 SHA512 bffd4cb1ea8d88b947b89f5bd1c55bbb8bbab8679f205216f87f932cc0170d2bbabfbe4ea8d32fb7c980826d3f7c4a20cd49c2fb36f288b5cdc4500ad9ff75cd
diff --git a/dev-python/sphinxcontrib-bibtex/metadata.xml b/dev-python/sphinxcontrib-bibtex/metadata.xml
new file mode 100644
index 000000000000..786ba057ec12
--- /dev/null
+++ b/dev-python/sphinxcontrib-bibtex/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrewammerlaan@riseup.net</email>
+ <name>Andrew Ammerlaan</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">sphinxcontrib-bibtex</remote-id>
+ <remote-id type="github">mcmtroffaes/sphinxcontrib-bibtex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.0.0.ebuild b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.0.0.ebuild
new file mode 100644
index 000000000000..f16eabd5b3ad
--- /dev/null
+++ b/dev-python/sphinxcontrib-bibtex/sphinxcontrib-bibtex-2.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extensions for BibTeX style citations"
+HOMEPAGE="https://github.com/mcmtroffaes/sphinxcontrib-bibtex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/oset[${PYTHON_USEDEP}]
+ dev-python/pybtex[${PYTHON_USEDEP}]
+ dev-python/pybtex-docutils[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}