summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-07-14 22:00:54 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-07-14 22:51:43 +0300
commitba98b49e6a90c2861385c12921a7f1da2a192192 (patch)
tree5e578eeb5ee8e6034f88b52b9f7fe3c44e48078b /dev-python
parentdev-ml/alcotest: update maintainer address (diff)
downloadgentoo-ba98b49e6a90c2861385c12921a7f1da2a192192.tar.gz
gentoo-ba98b49e6a90c2861385c12921a7f1da2a192192.tar.bz2
gentoo-ba98b49e6a90c2861385c12921a7f1da2a192192.zip
dev-python/whatthepatch: add 1.0.6
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/whatthepatch/Manifest1
-rw-r--r--dev-python/whatthepatch/whatthepatch-1.0.6.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/whatthepatch/Manifest b/dev-python/whatthepatch/Manifest
index 428b6bea90d1..6a2e2441ff89 100644
--- a/dev-python/whatthepatch/Manifest
+++ b/dev-python/whatthepatch/Manifest
@@ -1 +1,2 @@
DIST whatthepatch-1.0.5.tar.gz 31850 BLAKE2B dfded6069aa70051fb5f399c9f4707969be4dfc1dee853cd8eb7f36e074c2b595eddbae3efd534321dbbcce7a6658ef9e9bc7675ef466e0a486d930d62761e1e SHA512 d87a36a608a15bcf6d28d26afee40161e26f17fa3b011056388f9850896577f913a91066de8b6071ea15b28fa05f8d00acb997b18483ea56218df4efb40109ab
+DIST whatthepatch-1.0.6.tar.gz 31849 BLAKE2B cc540aa7455098a6f48e180defb173d25cc499d2c7415c639aef125cf0137e67c06ecdf18fb3337ef13e76e505ff598caa1b6a3d603c66dd38cb65f3f0a964ed SHA512 353866973b6a9b1d0bdb566d4c2eaf655a9a148d1acd73138cbbb5fbf5ec1d159391390857a34dfd75dca0c760168be720961e9d0d74dd8425849d641b2f5105
diff --git a/dev-python/whatthepatch/whatthepatch-1.0.6.ebuild b/dev-python/whatthepatch/whatthepatch-1.0.6.ebuild
new file mode 100644
index 000000000000..8480a90dc46d
--- /dev/null
+++ b/dev-python/whatthepatch/whatthepatch-1.0.6.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A patch parsing and application library."
+HOMEPAGE="
+ https://github.com/cscorley/whatthepatch/
+ https://pypi.org/project/whatthepatch/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+EPYTEST_DESELECT=(
+ # the test measures performance of the patch parser together with test data
+ # preparation, which can take long time in some interpreters, bug #907243
+ tests/test_patch.py::PatchTestSuite::test_huge_patch
+)
+
+distutils_enable_tests pytest