summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-14 11:23:29 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-14 14:26:21 +0200
commitb54393653a6ee9be02d7fe08a48284564e6a2447 (patch)
treeacbec6ec88092ef780244b7b40541c2d5455abd7 /dev-python
parentdev-python/sphinxcontrib-blockdiag: Add python@ as co-maint (diff)
downloadgentoo-b54393653a6ee9be02d7fe08a48284564e6a2447.tar.gz
gentoo-b54393653a6ee9be02d7fe08a48284564e6a2447.tar.bz2
gentoo-b54393653a6ee9be02d7fe08a48284564e6a2447.zip
dev-python/sphinx-testing: Bump to 1.0.1, EAPI=7, Py3.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/sphinx-testing/Manifest1
-rw-r--r--dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/sphinx-testing/Manifest b/dev-python/sphinx-testing/Manifest
index d12617ea8406..df086e6c0f27 100644
--- a/dev-python/sphinx-testing/Manifest
+++ b/dev-python/sphinx-testing/Manifest
@@ -1 +1,2 @@
DIST sphinx-testing-0.7.2.tar.gz 11040 BLAKE2B 503e38eabfe8dbe28942f9165a83db2dec0f9ac52e1e55f7298848b7a6b55244e1b5623bfda7f4e1380eab16ef81cf51c6bc11e919a8b45506f17759ae0ee181 SHA512 d267c74d97443db2df69914a825da969021e37fc61b8a664ef382504fa826387a95230bf9259b58c6f26721f33985fa2168d2714342a2166b59740cf1b3ad724
+DIST sphinx-testing-1.0.1.tar.gz 11513 BLAKE2B 46ede243507a0d90b2ad4b918deadb818491bb0ed15ce41886040c52650f9fd348ff57c03766fd1e7719bbb54726f8915e091cf94a5396da946102ca49fd07b2 SHA512 2d377c0c6fe8e34a463b35e96938507a3ca35fa06cd19a2682eb55825e1b88982a80a02ebb9a02a47f11ca5e8fe6a5b9e5c8114d955fa3b774e0148e82121818
diff --git a/dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild b/dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild
new file mode 100644
index 000000000000..1a69f9f5610e
--- /dev/null
+++ b/dev-python/sphinx-testing/sphinx-testing-1.0.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Testing utility classes and functions for Sphinx extensions"
+HOMEPAGE="https://github.com/sphinx-doc/sphinx-testing"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+ )"
+
+python_test() {
+ # NB: while tests don't stricly use nose, they rely on some side
+ # effects of using it
+ nosetests -v || die "Tests fail with ${EPYTHON}"
+}