summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-27 19:52:20 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-27 19:52:20 +0100
commitaa6a798087550df710dd8a241a371e394b2d34c7 (patch)
tree26a326ca07518a9de86c36ad12e935f70be99fe6 /dev-python
parentdev-python/jaraco-context: Remove old (diff)
downloadgentoo-aa6a798087550df710dd8a241a371e394b2d34c7.tar.gz
gentoo-aa6a798087550df710dd8a241a371e394b2d34c7.tar.bz2
gentoo-aa6a798087550df710dd8a241a371e394b2d34c7.zip
dev-python/zipp: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/zipp/zipp-3.7.0.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/zipp/zipp-3.7.0.ebuild b/dev-python/zipp/zipp-3.7.0.ebuild
deleted file mode 100644
index cc4d1d62a53a..000000000000
--- a/dev-python/zipp/zipp-3.7.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
-HOMEPAGE="https://github.com/jaraco/zipp"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-BDEPEND="
- >=dev-python/setuptools_scm-3.4.2[${PYTHON_USEDEP}]
- test? ( dev-python/jaraco-itertools[${PYTHON_USEDEP}] )
-"
-
-distutils_enable_sphinx docs \
- ">=dev-python/jaraco-packaging-3.2" \
- ">=dev-python/rst-linker-1.9"
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # speed tests are flaky by design
- test_zipp.py::TestPath::test_implied_dirs_performance
-)
-
-EPYTEST_IGNORE=(
- # Ignoring zipp.py from ${S} avoids ImportPathMismatchError with Python < 3.8
- # by ensuring only zipp from ${BUILD_DIR} is loaded
- zipp.py
-)
-
-python_prepare_all() {
- # dep of disabled test
- sed -i -e '/func_timeout/d' test_zipp.py || die
- distutils-r1_python_prepare_all
-}