summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-04-15 14:45:58 +0200
committerIan Delaney <idella4@gentoo.org>2016-04-15 22:30:53 +0800
commit9edad3e642c272619f7fefd9d9cb51944e231fb3 (patch)
tree0b4795d500e1e2f264160c71100f61daeae6f2f6 /dev-python
parentdev-perl/Growl-GNTP: version bump, 0.210.0 (diff)
downloadgentoo-9edad3e642c272619f7fefd9d9cb51944e231fb3.tar.gz
gentoo-9edad3e642c272619f7fefd9d9cb51944e231fb3.tar.bz2
gentoo-9edad3e642c272619f7fefd9d9cb51944e231fb3.zip
dev-python/superlance: new package, version 0.11
Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1261 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/superlance/Manifest1
-rw-r--r--dev-python/superlance/metadata.xml18
-rw-r--r--dev-python/superlance/superlance-0.11.ebuild41
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/superlance/Manifest b/dev-python/superlance/Manifest
new file mode 100644
index 000000000000..056f892078b4
--- /dev/null
+++ b/dev-python/superlance/Manifest
@@ -0,0 +1 @@
+DIST superlance-0.11.tar.gz 33882 SHA256 ab3aa27f2985c840f59f19b90e75b62e43d8d70e41b0cdc6523a884fb32f9d6e SHA512 bdf6da9e26f4db6f32f79cc27987fd75d2902ca6c098cf9c07785791fe50d3546348689391636eac25d963cd09edb2e57669e5526e68bddfd78c88eb9918fd91 WHIRLPOOL 9c85c8a68d60b195c5cb8d67a0f4e47cf5701c3b2b6711ad28ae1b11cf81723a9c0265e29f0cfed7d415d375a42abe0147101444b9fb969db598a3b786bb8140
diff --git a/dev-python/superlance/metadata.xml b/dev-python/superlance/metadata.xml
new file mode 100644
index 000000000000..6032000b3efd
--- /dev/null
+++ b/dev-python/superlance/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sautier.louis@gmail.com</email>
+ <name>Louis Sautier</name>
+ <description>Proxied maintainer; set to assignee in all bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">superlance</remote-id>
+ <remote-id type="github">Supervisor/superlance</remote-id>
+ <bugs-to>https://github.com/Supervisor/superlance/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/superlance/superlance-0.11.ebuild b/dev-python/superlance/superlance-0.11.ebuild
new file mode 100644
index 000000000000..30f77daf97f1
--- /dev/null
+++ b/dev-python/superlance/superlance-0.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A set of plugins to monitor and control supervisor"
+HOMEPAGE="https://github.com/Supervisor/superlance"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="app-admin/supervisor[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}