summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-10-29 02:33:27 -0400
committerTim Harder <radhermit@gentoo.org>2017-10-29 02:33:27 -0400
commit95f92d80863704da32adac409641c024c9896e1e (patch)
treed9a698cfcd043ef4d03acf83aeb843220b32b3f2 /dev-python
parentdev-python/execnet: fix metadata indentation consistency (diff)
downloadgentoo-95f92d80863704da32adac409641c024c9896e1e.tar.gz
gentoo-95f92d80863704da32adac409641c024c9896e1e.tar.bz2
gentoo-95f92d80863704da32adac409641c024c9896e1e.zip
dev-python/hypothesis: version bump to 3.33.0
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-3.33.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 21e3ce926d99..d832513f0042 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -1,2 +1,3 @@
DIST hypothesis-3.31.1.tar.gz 464365 SHA256 b2e5413e5424b433f013f4c7c5308130a55fa7dde346ffad2e0868139d442e57 SHA512 2bb0bcf1030374a17d0002901a9ffeb2bd522917428989206a3398e13dc0523703b9b39331cc503ee4d815ad48dca4826cc49379434767803373aa7b81a2625d WHIRLPOOL a46599f7e1a5c93e2de4dff00f3b40f75972cdbbab3ee943e1683774cb9dbbb5e7c6cfdbd700e08c72c772b13b21789ee39d6ee954ce47f77ee79a477ae5e5f2
+DIST hypothesis-3.33.0.tar.gz 467424 SHA256 cd10a68b65b160da6c957557255dc2aa89c8967c21169a79d765d4aae1d2a929 SHA512 3e89fa183381f2df556016ff4af17d2731685b019aed74d5f8dccd53ad262dce107f83f105b7e950a579ef247cc9b8336f15ee321292522118fa4c3487a21138 WHIRLPOOL ce1d30d72880d841c116dc2b8edd700fa483c845d7c7271efeceb94ba3336e5ed9493d0032c8aa4efb15d67a95490f3bb556b63a4be6168c53ed06406558808b
DIST hypothesis-3.6.0.tar.gz 73586 SHA256 ecb0e711ab83032c54605d88fda1e07ca5c6025bdb5e91deab96eca29491f678 SHA512 cb885628e5c38ab9312cfb177ebc3c014617d21031737f5fba343ba485c1b8ff82b1302e7bc1d3e79192bfd8324fd0501498c968f3ac8343829f8965f6354389 WHIRLPOOL 189c788fdd0a326879a468061c271b14056da5f7dc1d5975e8f360cd5a91957eb8f79c26a045fbe49d7b11f7cc09024d3d09a353321b1dda1d4d96b452fd9e7b
diff --git a/dev-python/hypothesis/hypothesis-3.33.0.ebuild b/dev-python/hypothesis/hypothesis-3.33.0.ebuild
new file mode 100644
index 000000000000..4869c0b7b9eb
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-3.33.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis-python https://pypi.python.org/pypi/hypothesis"
+SRC_URI="https://github.com/HypothesisWorks/hypothesis-python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${PN}-python-${PV}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pytest support" dev-python/pytest
+}