summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-22 19:06:28 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-22 19:55:05 +0100
commit8b81414fa366afa72b0b743c2b54e609d29ac201 (patch)
tree9a2686099c0a8fdd62c705bbe8c2a374898526a4 /dev-python
parentdev-python/snappy: Bump to 0.6.1 (diff)
downloadgentoo-8b81414fa366afa72b0b743c2b54e609d29ac201.tar.gz
gentoo-8b81414fa366afa72b0b743c2b54e609d29ac201.tar.bz2
gentoo-8b81414fa366afa72b0b743c2b54e609d29ac201.zip
dev-python/loky: Bump to 3.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/loky/Manifest1
-rw-r--r--dev-python/loky/loky-3.1.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/loky/Manifest b/dev-python/loky/Manifest
index aff995481036..dc701cbd202c 100644
--- a/dev-python/loky/Manifest
+++ b/dev-python/loky/Manifest
@@ -1 +1,2 @@
DIST loky-3.0.0.tar.gz 152463 BLAKE2B 99f0a1fc85e879626d12402dd4fee4b92345eab9520b1afaf95bbf869d2dc9e429f1f9810554e10d97f0ecbc4add28b1cbaee0477de05aa366faeb335eaef7c8 SHA512 ad171bfac031ab4d6749bde416031e905eb29adb97dab9c3348791c9df78b17e1e3eab8a354954d7c16fb2095ccc03d26cf2153fe53a546007a7a89c6046cb36
+DIST loky-3.1.0.tar.gz 139211 BLAKE2B 32e95312c40d6f8d8f9fc8daf5a1e85f1b874cbb902a4885621983d84a5fa9da42f05ff7d5d6bf58cf04a320c04c6e698ff0105cdad9ddd3248a109cc71c9883 SHA512 8bf6b032bb4f770d89c8de93d95c5805fa90dae34f2754f14c3a9fe7860230e8ce8ea97e1b09fa2cdf67f8aecdbd6d1e47ae4fb746fb1c6912d2dd65033f5b6f
diff --git a/dev-python/loky/loky-3.1.0.ebuild b/dev-python/loky/loky-3.1.0.ebuild
new file mode 100644
index 000000000000..61f9d0dae1c4
--- /dev/null
+++ b/dev-python/loky/loky-3.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Robust and reusable Executor for joblib"
+HOMEPAGE="https://github.com/joblib/loky"
+SRC_URI="
+ https://github.com/joblib/loky/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cloudpickle[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ EPYTEST_DESELECT=(
+ # docker, seriously?
+ tests/test_loky_module.py::test_cpu_count_cfs_limit
+ # hangs, and even pytest-timeout does not help
+ tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill
+ )
+
+ # high memory test needs a lot of memory + is broken on 32-bit platforms
+ epytest --skip-high-memory -p no:xvfb
+}