summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-05 17:06:15 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-05 17:06:30 +0200
commit6adeb3334fd2a84ff2f03033cf0c01d820e8d6d2 (patch)
tree5b18f9c2c3629c8d6161bde1162f3b1441633453 /dev-python
parentdev-libs/rocm-opencl-runtime: 2.9.0 version bump (diff)
downloadgentoo-6adeb3334fd2a84ff2f03033cf0c01d820e8d6d2.tar.gz
gentoo-6adeb3334fd2a84ff2f03033cf0c01d820e8d6d2.tar.bz2
gentoo-6adeb3334fd2a84ff2f03033cf0c01d820e8d6d2.zip
dev-python/markdown: Bump to 3.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/markdown/Manifest1
-rw-r--r--dev-python/markdown/markdown-3.1.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/markdown/Manifest b/dev-python/markdown/Manifest
index 7d4384d40996..be200e553d67 100644
--- a/dev-python/markdown/Manifest
+++ b/dev-python/markdown/Manifest
@@ -3,3 +3,4 @@ DIST Markdown-2.6.5.tar.gz 301781 BLAKE2B 527a84bc8c4a891e64749bce273bf10c439376
DIST Markdown-2.6.8.tar.gz 307330 BLAKE2B 6867f15425bd84bc030ab52000dc2f83bff0c9885854cec4a2a785f80b18129160bc57da30226fe17f42043b4938482e2e4eff9cdb3d4370b0146cc09f1ff576 SHA512 85c1a16ebb50af79f378eb2fa936342df6174a4f597a74fee6d0495ef2bc4c7c8337463799e427cb6788b3429e400309958b5c4784f536593047ab2e47ac7c23
DIST Markdown-2.6.9.tar.gz 271564 BLAKE2B 792e438955a55de9f473107618516d17129caa4d02097d510992d25715a4f28aae005781b3a2e4fe53692bc12e96ab49008b66ff49247bf1685bac4c7607e0b6 SHA512 d00c800dc7c1ae0753cbcddd755ade7d593a8d9c9d4ffc6eb8765233a44027a75b68948c14b4469d7aa0e7f74029e9f60159d81ed40b3d2e770c68a81533ccfa
DIST Markdown-3.0.1.tar.gz 284084 BLAKE2B 6a9250295057ed32b389e1aeecf9aa3acac37ef48e6ca93a4821eb56a2323d65c1aed99799bf05811f27f45ba61f7bb704f69c6d2be706d8d2764c026e937905 SHA512 c648c1b8ecb3c907ff2bd636ec6c08b4b629967fb916913f77db641f6d61b83d16929af2f15f5695c8cdb9614031606110e02a7e0bbb3aab0be38a8e285f12f1
+DIST Markdown-3.1.1.tar.gz 294136 BLAKE2B 9fd024f64f7aaa774a49f60e312e47bbc2ff0f368f083e4dfd0c38d1f12839dfcf3455f1d0c8cb0b9c851fe0d3a779c70784859f1682703bd6022d57b6548235 SHA512 78f089f2eef5c73d683ac96fd20c87145e243d12b0f230b9b0228b995035fbb084dde40be788679c63637f05956487ad520cc9dd61d133926bf13521aa600090
diff --git a/dev-python/markdown/markdown-3.1.1.ebuild b/dev-python/markdown/markdown-3.1.1.ebuild
new file mode 100644
index 000000000000..2b302e7635f8
--- /dev/null
+++ b/dev-python/markdown/markdown-3.1.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the markdown markup language"
+HOMEPAGE="
+ https://python-markdown.github.io/
+ https://pypi.org/project/Markdown/
+ https://github.com/Python-Markdown/markdown"
+SRC_URI="mirror://pypi/M/${PN^}/${P^}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc pygments test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytidylib[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+# source cites pytidylib however from testruns it appears optional
+RDEPEND="pygments? ( dev-python/pygments[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${P^}"
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_docs
+ HTML_DOCS=( "${BUILD_DIR}"/docs/. )
+ fi
+}
+
+python_test() {
+ esetup.py test
+}