summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-02 08:04:54 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-02 08:40:02 +0200
commit665975498dba43da55585aeccc698a4e8a7facee (patch)
tree6c97dc96f39a0ca6c751c32e832cd809506918bd /dev-python
parentdev-python/django: Bump to 3.0.10 (diff)
downloadgentoo-665975498dba43da55585aeccc698a4e8a7facee.tar.gz
gentoo-665975498dba43da55585aeccc698a4e8a7facee.tar.bz2
gentoo-665975498dba43da55585aeccc698a4e8a7facee.zip
dev-python/django: Bump to 2.2.16
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/django/Manifest1
-rw-r--r--dev-python/django/django-2.2.16.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/dev-python/django/Manifest b/dev-python/django/Manifest
index beb4ab4a42bf..a38bb7aa54d5 100644
--- a/dev-python/django/Manifest
+++ b/dev-python/django/Manifest
@@ -1,5 +1,6 @@
DIST Django-2.2.13.tar.gz 8879757 BLAKE2B 4a7986805c6a3674d47aa82b97f31ae63968dd7c0f12db672207cd1d97076acb681fe44e730147122911684b36d7f1e9d5ea18c054d4c40c68b460300fd9294b SHA512 6daf3486d2f19eb159193df77a7525e5173ba5889ad5c587a6ec6bbf02c4ea94fa90b9a30a5310932fc9353a22c413208ab724c05740f844eccfe610da3ca68a
DIST Django-2.2.15.tar.gz 9023679 BLAKE2B 9619d0ac45a8256a1e605f447b89df6266d67d98969baffd41a9184165e14d57d4edfb898f64a6633cc0f4c23b24a35b16cb446c920d8baf58f771c69d8697ee SHA512 bb91e5b621be54570f8c7676f820ff93fbf0546dea79e035eebd60b70c5c872b0de65395a4606f07af7b9c77de2cf218aaef8ff489fcfabaf5c9b75d28e42dc2
+DIST Django-2.2.16.tar.gz 8884774 BLAKE2B e65074c44e35921f6c40ca9e2a5fee53ce9a956a7503b96a33c8dbb4588bb0928d2e2b605f1117c3c75cdc84d6c7d1bfe52f4e7888fbe300adb5411a55b0ac27 SHA512 eabcdfc17e27c579001e4739268abd13bebbb018db1a7dbe4fb8482d32320b85bd16b3b18428084c0df947094f23f7cb4b12a3a55bc370748d7d8746af22bc3b
DIST Django-3.0.10.tar.gz 8958332 BLAKE2B 0ff17da9d9175b080d81e334e46ec6daaec5e4cd48f5d9a614c84b448a6d4b93d304b3fd25bcee665d65f589a8f94cf83f002bbd7a27975d23e3516286784e01 SHA512 fcce2815f966a5eb0f7986c16d065b352c73ea2ea4fc1422d440487d84162c5a93aa45b9173ba5d62d6caee2e976a9ac818f228b47ed7f4f50deda27bac995e9
DIST Django-3.0.8.tar.gz 9080731 BLAKE2B b3276527c9c5eba18b380204c498ebd5724e5211640ead9e05284eb013f907ce6799125b29e2030bc37ecd5a1022e6eb3f193eca5e2c6520adef630d6d2114a9 SHA512 92d169fb37883355f1898fc13b54b6732ec14d71f77e4b91db30dd9bfb5df8b34c1c9566af6ddc37e00a9e3eadd38b6a51ff604a4da4285167f66b55215be301
DIST Django-3.0.9.tar.gz 9081099 BLAKE2B 502f9cf1fafff50d92c771e845319f5406722cdb8ca0570688bb96e7fbc765cee319325b0340b722afeb0a304316d30408ca92154623ad4934877cbdc8ee9259 SHA512 1244b9cff26b9e8d9a3d611e0a39981bd1a46d68fa734a58ba12fd51eeb023fb053605372d7b41b51027e4e609f1870d25f7e0584d0449ceeb8d877f674e49b4
diff --git a/dev-python/django/django-2.2.16.ebuild b/dev-python/django/django-2.2.16.ebuild
new file mode 100644
index 000000000000..332ed12688eb
--- /dev/null
+++ b/dev-python/django/django-2.2.16.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..8} )
+PYTHON_REQ_USE='sqlite?,threads(+)'
+
+inherit bash-completion-r1 distutils-r1 eutils
+
+MY_PN="Django"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
+SRC_URI="https://www.djangoproject.com/m/releases/$(ver_cut 1-2)/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+# admin fonts: Roboto (media-fonts/roboto)
+LICENSE+=" Apache-2.0"
+# admin icons, jquery, xregexp.js
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc sqlite test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.2[${PYTHON_USEDEP}]"
+# gettext: https://code.djangoproject.com/ticket/31850
+BDEPEND="
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ $(python_gen_impl_dep sqlite)
+ ${RDEPEND}
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/selenium[${PYTHON_USEDEP}]
+ dev-python/tblib[${PYTHON_USEDEP}]
+ <sys-devel/gettext-0.21
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.7-bashcomp.patch
+)
+
+distutils_enable_sphinx docs --no-autodoc
+
+python_test() {
+ # Tests have non-standard assumptions about PYTHONPATH,
+ # and don't work with ${BUILD_DIR}/lib.
+ PYTHONPATH=. "${EPYTHON}" tests/runtests.py --settings=test_sqlite -v2 ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp extras/django_bash_completion ${PN}-admin
+ bashcomp_alias ${PN}-admin django-admin.py
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "Additional Backend support can be enabled via"
+ optfeature "MySQL backend support" dev-python/mysqlclient
+ optfeature "PostgreSQL backend support" dev-python/psycopg:2
+ echo ""
+ elog "Other features can be enhanced by"
+ optfeature "GEO Django" "sci-libs/gdal[geos]"
+ optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
+ optfeature "ImageField Support" dev-python/pillow
+ optfeature "Password encryption" dev-python/bcrypt
+ optfeature "High-level abstractions for Django forms" dev-python/django-formtools
+}