summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-01 08:55:01 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-01 09:59:18 +0200
commit660cec4002150d64f1c4dba07c8149ea2ffdecfc (patch)
tree0495371a822e78c1a7bf20f2553354580c04e1b6 /dev-python
parentdev-util/debugedit: Bump to 4.16.0 (diff)
downloadgentoo-660cec4002150d64f1c4dba07c8149ea2ffdecfc.tar.gz
gentoo-660cec4002150d64f1c4dba07c8149ea2ffdecfc.tar.bz2
gentoo-660cec4002150d64f1c4dba07c8149ea2ffdecfc.zip
dev-python/botocore: Bump to 1.18.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.18.9.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index f4581925b34e..d316944cd0cc 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -10,3 +10,4 @@ DIST botocore-1.18.5.tar.gz 6852318 BLAKE2B 3aeca749a143cba59ce637935a711df14351
DIST botocore-1.18.6.tar.gz 6854270 BLAKE2B d5d8a321adde9c16706768633a8ed32d4db086ec2634dae8e2057c2217b2e729bfd02e2968a9749d660ded41c883ac153a80083256a27496b4b59013b57520e5 SHA512 d4c3f79f1531f85f2ab793bcdeb13f8f51c333e704f404415e49f50d310a715f752f19bc4bc7ce07c5b20f19c5924008f47146f737c318b9204d8a4af4f6fe8d
DIST botocore-1.18.7.tar.gz 6854828 BLAKE2B d4b3095d29fea7157ca8b5499726886527941e04e0c2f274eba3573acc8a8c6ff26fd734f144335e03b9bb25c9fba128bb817a68178c284406a232c1d8881050 SHA512 c94ef62d4cc89317cb13fd96f5661de8ea3b1478c4dbce039d6e3b6af6ac4e58e3e5cf2d7d62c90e5b6b046303fc1e9273041640ae4907086591213ba3f79877
DIST botocore-1.18.8.tar.gz 6865779 BLAKE2B 5b67b67deba73a0a69d4b413bfb105b3eeae5d62a38b0f109d172652270e490eed55b42c8a67c14039aec3f8f0b8b1d1dd9d6945bf9c86d1466bf69d4dc4237f SHA512 467b8ac3c3860777efbf37868add24fc56eecf65003c03692f45669e4ece965c129e18fe3ee0e1ed75b02c886f5762186572927c5e99b3eae85724d7443072d4
+DIST botocore-1.18.9.tar.gz 6897783 BLAKE2B 7b449d58febdf3ca3f04bd75e30c3953d6701e5204578a99ce011cce28c5fb30341da5120d2c105b1240ac20dbe80fbfe958d2c5055a04b688ad099fb616342b SHA512 2cfc6c633a216ad091f02021966b3233bdb41f3bfd46c8c6f13bc7ab653024aba21eeb310c87112ad210385fc2316f77117c9ddf26ed0f0df82971b53dd7223b
diff --git a/dev-python/botocore/botocore-1.18.9.ebuild b/dev-python/botocore/botocore-1.18.9.ebuild
new file mode 100644
index 000000000000..ba67bf7ac94b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.18.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}