summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-05 22:31:41 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-05 22:50:38 +0100
commit59c15cd1a779bd29b50cc82722119f53453dd0a4 (patch)
treec5e99e6ba62f52cfcb922303b35a2cb23e781372 /dev-python
parentdev-python/markups: Bump to 3.1.1 (diff)
downloadgentoo-59c15cd1a779bd29b50cc82722119f53453dd0a4.tar.gz
gentoo-59c15cd1a779bd29b50cc82722119f53453dd0a4.tar.bz2
gentoo-59c15cd1a779bd29b50cc82722119f53453dd0a4.zip
dev-python/setuptools: Bump to 54.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/setuptools/Manifest1
-rw-r--r--dev-python/setuptools/setuptools-54.1.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/setuptools/Manifest b/dev-python/setuptools/Manifest
index 1ebb6ed577a2..5bf5ffcca19e 100644
--- a/dev-python/setuptools/Manifest
+++ b/dev-python/setuptools/Manifest
@@ -2,3 +2,4 @@ DIST setuptools-51.3.3.tar.gz 2053035 BLAKE2B 73b33359f10f900233b82e68c917816096
DIST setuptools-53.0.0.tar.gz 2050503 BLAKE2B b1ebe5a9776917fe9a21a13a4db613fd05aa1f61043482487013bcfed7802ff1b984fe0f72623b092eee7ebfb9debd5f71732223220bc2b73a6ece0a7ec86a2c SHA512 d045198210f09c5f2acbd487d3dd291cd7ce814bebe331f1876c133cd28f56d368717c7bd4a875b439c9cc8c9488dc9a7d3e27ab791cce419f78b87fcfd8fff6
DIST setuptools-53.1.0.tar.gz 2051159 BLAKE2B f4148df45f5c62acd6acae833619dcae50f131da91ece1a2e1231620d4800294f14dab6c72ca5b2ffd31191c4e3306a869abdba349adcec5746600fc067b340d SHA512 0ca02e9b997623268d8f73b73ee6a4b1ad513802cbc75c74124a85bd5ca7bfaea5cf7cccb706334c0dac2c8a0674a5bc2cea10f44f99f881ad893c8337af3da2
DIST setuptools-54.0.0.tar.gz 2052086 BLAKE2B b96b8ac1119a9ece7d6a7e481a8d078f6ea65957be679549381b67e26498a6d403aca38b8ee8ca832c8e1045f960114e037787863ea6247bc87a92c1301c11fb SHA512 b13ad8aa13da63d9504064fb702632d0d17dd81eee8c09b9d38d30a6e4d625a600f0b3e7349e45354b444c25d5caccb5407bdecdd220af2e283f4baccd6f675f
+DIST setuptools-54.1.0.tar.gz 2052744 BLAKE2B a62bc9938ce5f39ac2a828180e03f82cc9481ab913c090f3358cb8408ae9c688aa53210b327ded4d0e652cbd97036b320cd67c349d1816fda39f10bc090df5aa SHA512 21259140f9f032b5431e33b32492b910561ecd7c3587a28fc71c14d03099d36ea746c81b0a9e476bd6fe12b9c61cd03a7e60eb9b673e0a249cf8e11df1a0e734
diff --git a/dev-python/setuptools/setuptools-54.1.0.ebuild b/dev-python/setuptools/setuptools-54.1.0.ebuild
new file mode 100644
index 000000000000..9bc11f0ea338
--- /dev/null
+++ b/dev-python/setuptools/setuptools-54.1.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+# Set to 'manual' to avoid triggering install QA check
+DISTUTILS_USE_SETUPTOOLS=manual
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Collection of extensions to Distutils"
+HOMEPAGE="https://github.com/pypa/setuptools https://pypi.org/project/setuptools/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/jaraco-envs[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-path-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/pytest-fixture-config[${PYTHON_USEDEP}]
+ dev-python/pytest-virtualenv[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+PDEPEND="
+ >=dev-python/certifi-2016.9.26[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+# Force in-source build because build system modifies sources.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DOCS=( {CHANGES,README}.rst )
+
+python_test() {
+ distutils_install_for_testing --via-root
+ local deselect=(
+ # network
+ 'setuptools/tests/test_virtualenv.py::test_pip_upgrade_from_source[None]'
+ setuptools/tests/test_distutils_adoption.py
+ # TODO
+ setuptools/tests/test_easy_install.py::TestSetupRequires::test_setup_requires_with_allow_hosts
+ # this one's unhappy about pytest-xdist but one test is not worth
+ # losing the speed gain
+ setuptools/tests/test_build_meta.py::TestBuildMetaBackend::test_build_sdist_relative_path_import
+ )
+
+ # test_easy_install raises a SandboxViolation due to ${HOME}/.pydistutils.cfg
+ # It tries to sandbox the test in a tempdir
+ HOME="${PWD}" pytest -vv ${deselect[@]/#/--deselect } \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" \
+ setuptools || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ export DISTRIBUTE_DISABLE_VERSIONED_EASY_INSTALL_SCRIPT=1
+ distutils-r1_python_install
+}