summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-01-30 18:28:43 +0100
committerBenda Xu <heroxbd@gentoo.org>2020-02-09 20:43:49 +0800
commit55c256add4c40c3ea82be950a39952f1ab78dfe7 (patch)
treedfd5741808edd1104bc98307f1d8f066d8efef07 /dev-python
parentdev-python/ordered-set: A MutableSet that remembers its order (diff)
downloadgentoo-55c256add4c40c3ea82be950a39952f1ab78dfe7.tar.gz
gentoo-55c256add4c40c3ea82be950a39952f1ab78dfe7.tar.bz2
gentoo-55c256add4c40c3ea82be950a39952f1ab78dfe7.zip
dev-python/xdoctest: A rewrite of Python's builtin doctest module
(with pytest plugin integration) but without all the weirdness Bug: https://github.com/gentoo/gentoo/pull/14344 Bug: https://bugs.gentoo.org/705872 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/xdoctest/Manifest1
-rw-r--r--dev-python/xdoctest/metadata.xml9
-rw-r--r--dev-python/xdoctest/xdoctest-0.11.0.ebuild40
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/xdoctest/Manifest b/dev-python/xdoctest/Manifest
new file mode 100644
index 000000000000..b2f56e769efb
--- /dev/null
+++ b/dev-python/xdoctest/Manifest
@@ -0,0 +1 @@
+DIST xdoctest-0.11.0.tar.gz 123871 BLAKE2B ef766ae79b1566a243abbb31671a6e57184196079cda146081c73cf4aa2583b612b438ea8ff031a1c3d4da612034bccb1990a954ad4d2af55546edd7f7085238 SHA512 63629435e976d2ece770b13432f1857127e7d9c9c954e11e904c1f25b1a9e82d5cf99ff912656260f6c4ed8b08e27ab0fb2d39e621d94ccac9c797fc294bcc62
diff --git a/dev-python/xdoctest/metadata.xml b/dev-python/xdoctest/metadata.xml
new file mode 100644
index 000000000000..ca93985fb0db
--- /dev/null
+++ b/dev-python/xdoctest/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-python/xdoctest/xdoctest-0.11.0.ebuild b/dev-python/xdoctest/xdoctest-0.11.0.ebuild
new file mode 100644
index 000000000000..ddcfe852c5c4
--- /dev/null
+++ b/dev-python/xdoctest/xdoctest-0.11.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
+HOMEPAGE="https://github.com/Erotemic/ubelt"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+
+python_prepare_all() {
+ # fails because the ebuild environment location is not the expected location
+ sed -i -e 's:test_xdoc_console_script_location:_&:' \
+ testing/test_entry_point.py || die
+
+ # xdoctest has to be in PATH for this to work
+ sed -i -e 's:test_xdoc_console_script_exec:_&:' \
+ testing/test_entry_point.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH="${WORKDIR}/${P}"
+ pytest -vv || die "Test fail with ${EPYTHON}"
+}