summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-17 16:07:11 +0000
committerSam James <sam@gentoo.org>2021-01-17 16:16:02 +0000
commit4a50acbea48db2f2423037448322123c9fb8f2e8 (patch)
tree03576291aeae0a1fe29d08a60adf06a21b8bf501 /dev-python
parentdev-python/gevent: bump to 21.1.0 (diff)
downloadgentoo-4a50acbea48db2f2423037448322123c9fb8f2e8.tar.gz
gentoo-4a50acbea48db2f2423037448322123c9fb8f2e8.tar.bz2
gentoo-4a50acbea48db2f2423037448322123c9fb8f2e8.zip
dev-python/ijson: bump to 3.1.3
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ijson/Manifest1
-rw-r--r--dev-python/ijson/ijson-3.1.3.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/ijson/Manifest b/dev-python/ijson/Manifest
index ce6063ee0044..db0eeed3ed47 100644
--- a/dev-python/ijson/Manifest
+++ b/dev-python/ijson/Manifest
@@ -1 +1,2 @@
DIST ijson-3.1.1.tar.gz 124875 BLAKE2B 6f20efa076cf9e9a9f22eec65c7658440cc2ddffc2bf88054025f76f2df48e395d1c11a52501a45e7b5301448ce5874fb3e62d9111963f49f976ee68836c39d1 SHA512 c693444ac757c3b6e1f762d4a877a82b11ccaaecc922d34b868d236a78d9cf8f8648cb6d1188f0444caf61a0758f3080d3bfbd79c1ee51114bbd7c0a34bc633e
+DIST ijson-3.1.3.tar.gz 125658 BLAKE2B 3866c89b3dab6f55138b51d52c55a1b2c83e4e26d98e08724cd3d96ccb28a7d2a5fb1889e59f499cfe3b4ee8642933f88fbb18111ac94a8195a97109fbf8a08f SHA512 f4da9e44cc42fac7d9eeb6ba897ba7c3b477e07b4fb6e91abda59a83638d29dc41a845ba9ff5907130657a78ccfb788a6b88d8026f58b2095174e6939e25ef8a
diff --git a/dev-python/ijson/ijson-3.1.3.ebuild b/dev-python/ijson/ijson-3.1.3.ebuild
new file mode 100644
index 000000000000..75895bfd275a
--- /dev/null
+++ b/dev-python/ijson/ijson-3.1.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+inherit distutils-r1
+
+MY_PV="${PV//_p/.post}"
+DESCRIPTION="Iterative JSON parser with a Pythonic interface"
+HOMEPAGE="
+ https://github.com/ICRAR/ijson
+ https://pypi.org/project/ijson/
+"
+SRC_URI="https://github.com/ICRAR/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-libs/yajl"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest