summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-13 05:58:54 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-13 05:58:54 +0200
commit41604e30e3e7209476de7579b949cf3276c25152 (patch)
tree07ca77d3bd46a1c15a1b8159c9f0e1d17a8edfef /dev-python
parentdev-python/trimesh: Bump to 4.0.0 (diff)
downloadgentoo-41604e30e3e7209476de7579b949cf3276c25152.tar.gz
gentoo-41604e30e3e7209476de7579b949cf3276c25152.tar.bz2
gentoo-41604e30e3e7209476de7579b949cf3276c25152.zip
dev-python/zeroconf: Bump to 0.116.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/zeroconf/Manifest1
-rw-r--r--dev-python/zeroconf/zeroconf-0.116.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index e34be2bd4ed3..3811bff5055c 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -5,4 +5,5 @@ DIST zeroconf-0.114.0.tar.gz 156001 BLAKE2B b3bc076746f5d510ba655dc5de748e7ff7cb
DIST zeroconf-0.115.0.tar.gz 156238 BLAKE2B 5f32c06e247bff5bfbd0ea53588458e8da6e94a2ee0a33627de1195c6e34fffee7c403cc8c6e234f4ab91cde10af50b3714b6493e5ae33f0523fdb8fd2f8f6bc SHA512 95d0c106e4a5bd5a25d0c91224642ada7cefbe16e3a4fbfff7c31b03c7359d34160c120adb9d4c06fb50be2cb20e298a1e775cd8c7b62f7207d04be59f49f6d8
DIST zeroconf-0.115.1.tar.gz 156318 BLAKE2B 1322b3ccf7d4d749642bb813b1655aefb410c1e953b89edb6a07196031e8a8fb8cfc923fd5d4a7149b7b25e5a16612ec86c6f353caf326d6cc3cff9a6881f7a3 SHA512 786e0dc1e7a321e37e491220f7aa83c5678ef7396bcf844d4928433fa7a1f43d1c5bb4dca10372ea982de5fb7640f3f8bb4b304ad59f9c6b4017c594bc54af61
DIST zeroconf-0.115.2.tar.gz 156482 BLAKE2B 80a1c0af87ffaec73505f48f1b38b8f99b578d6573970529b4613fd46174f635d2ff24ae6b1631a2747bb4eb542ac7180cf7bb473aa69f91ce90e64b463ec43d SHA512 1a1fd7f5cf3356fa189f209dc9ea0f8319b0d101ec28ed0ae3304656ca488afab0258cf6bce6d13919554555ea1a51b59599dba5afccc315df15d4efbc8cdb13
+DIST zeroconf-0.116.0.tar.gz 156565 BLAKE2B 2d261eb9602ea6db71e39cccd740b09366f86a37b9c3b9e4f61373fd525f2ceb7bf2235ee2adacbf7bea8293920ea94c8152e11786a1f483f3605908c988ebd4 SHA512 649b01f49fd0229739b0a3beb0c528f4a3c7841b77fdadcab5356f1e69f21ba2a89d4a948a97b8592b137f6a76be463768e83a399aa9850f08fee6bb01092320
DIST zeroconf-0.91.1.tar.gz 150551 BLAKE2B 220e6b5684d503c7d1c594196ffa7ecc4f06975accad2ad64a6dd0a75881326110bbf897e74a2a176307fc392fc9fce903c77bbf9fc70fec84f193072bd7a016 SHA512 852946a2f823de1dc25dda5321ec23c67e3893fd8dcf55391e001afb01eb4c8143813aaa0950fddbea6634975eb0904a6e3b500cbe082e843da301c0cd704e9a
diff --git a/dev-python/zeroconf/zeroconf-0.116.0.ebuild b/dev-python/zeroconf/zeroconf-0.116.0.ebuild
new file mode 100644
index 000000000000..b3ff07347a6d
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.116.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-3[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export REQUIRE_CYTHON=1
+
+python_test() {
+ local -x SKIP_IPV6=1
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}