summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-19 06:27:20 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-19 06:27:20 +0200
commit3a9fd7e7a930548ade2d3b50951c5f8e51835798 (patch)
treee8eb9293ee9c3d0b3c65342dd52451164cd76569 /dev-python
parentdev-python/fitsio: Remove old (diff)
downloadgentoo-3a9fd7e7a930548ade2d3b50951c5f8e51835798.tar.gz
gentoo-3a9fd7e7a930548ade2d3b50951c5f8e51835798.tar.bz2
gentoo-3a9fd7e7a930548ade2d3b50951c5f8e51835798.zip
dev-python/fitsio: Bump to 1.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/fitsio/Manifest1
-rw-r--r--dev-python/fitsio/fitsio-1.2.4.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/fitsio/Manifest b/dev-python/fitsio/Manifest
index a08d8b604256..84fc18966eea 100644
--- a/dev-python/fitsio/Manifest
+++ b/dev-python/fitsio/Manifest
@@ -1 +1,2 @@
DIST fitsio-1.2.3.gh.tar.gz 4507743 BLAKE2B 2b38b9b1be3eb7ab5ed67954f6c1310c03a99cbae71bb5716702d31bc69e09f8d73fb86696edb06bba78093d48ad784f280e7023fadc932190a82ce6748cf5af SHA512 11c2e8e26019bdc364d2a566c0680baa85d93a0a49eb9e5fc0ccc79f2566c616634a8bf10f1d8dbb4c1393675d11bb8d4e469d2f30a8cb88bfa73697ac9d4c57
+DIST fitsio-1.2.4.gh.tar.gz 4540756 BLAKE2B 445a6d2c5dd267fdf7eca5359eb378930b8a111c24c68c1728f00818aa2f04dabe486147e1c56fd36c8a096e4bcd89c6ed382b9bbfbd29f9b24f9a4195fa17ae SHA512 ca51957a413ee45b0adc71c97409e8055acf1c27f8f42838a4814ed9b5530a30c75579a4a567199d6524bdcd32de5c82fabdee1440577f1cc915543285ee7fe1
diff --git a/dev-python/fitsio/fitsio-1.2.4.ebuild b/dev-python/fitsio/fitsio-1.2.4.ebuild
new file mode 100644
index 000000000000..816390c41e42
--- /dev/null
+++ b/dev-python/fitsio/fitsio-1.2.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to read from and write to FITS files"
+HOMEPAGE="
+ https://github.com/esheldon/fitsio/
+ https://pypi.org/project/fitsio/
+"
+SRC_URI="
+ https://github.com/esheldon/fitsio/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-python/numpy-1.11:=[${PYTHON_USEDEP}]
+ >=sci-libs/cfitsio-4.4.0:0=
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests pytest
+
+export FITSIO_USE_SYSTEM_FITSIO=1
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest
+}