summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-14 19:03:16 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2018-11-14 19:21:05 -0800
commit34f950333fc55bd3649b37f6f7f0ee0ab608ba46 (patch)
treef79a6ae98283daf32843084aa031b9f89c73b8c9 /dev-python
parentnet-libs/grpc: http -> https HOMEPAGE (diff)
downloadgentoo-34f950333fc55bd3649b37f6f7f0ee0ab608ba46.tar.gz
gentoo-34f950333fc55bd3649b37f6f7f0ee0ab608ba46.tar.bz2
gentoo-34f950333fc55bd3649b37f6f7f0ee0ab608ba46.zip
dev-python/grpcio: version bump to 1.16.1
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/grpcio/Manifest1
-rw-r--r--dev-python/grpcio/grpcio-1.16.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/grpcio/Manifest b/dev-python/grpcio/Manifest
index e3589291b88b..b613503e0b91 100644
--- a/dev-python/grpcio/Manifest
+++ b/dev-python/grpcio/Manifest
@@ -1 +1,2 @@
DIST grpcio-1.16.0.tar.gz 14519470 BLAKE2B 872ef15a7994303ce7ac0a573e49c94260eb8480d8ee94e25471ec9395827fafd3f5e3bd6f4793eb15091827e6d780b8dd6d01f38eef85db80fb234a710f370b SHA512 37d5940f1543cebdabf2b1340a042f98e5f321c42d92d05c88631c0eae42d94d3fe86893a21704a22b70c1fbd70bf091c1af2b51cd5c1d316dd8f0a586fb0eb7
+DIST grpcio-1.16.1.tar.gz 14514047 BLAKE2B e4fc7f196f3e377afb0a103aca60337dd63b3b0f84846e7e2a4622a0102d4300782f08367e1429e1fd021dd90b151f17dd927a25a749f35724c7d2a41a6943a6 SHA512 efd7fb36a61e2ee872c0807a8198cabe8f1f9003bd5bce7cd46c75541752c0f745db02bbfe3f37f572531e15df60913f2b08b678545f176fe683f3e64e22124f
diff --git a/dev-python/grpcio/grpcio-1.16.1.ebuild b/dev-python/grpcio/grpcio-1.16.1.ebuild
new file mode 100644
index 000000000000..312146bd5e1a
--- /dev/null
+++ b/dev-python/grpcio/grpcio-1.16.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="High-performance RPC framework (python libraries)"
+HOMEPAGE="https://grpc.io"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=dev-libs/openssl-1.0.2:0=[-bindist]
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ net-dns/c-ares:=
+ !<net-libs/grpc-1.16.0[python]
+ sys-libs/zlib:=
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_compile() {
+ export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
+ export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
+ export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
+ export GRPC_PYTHON_BUILD_WITH_CYTHON=1
+ distutils-r1_python_compile
+}