summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-02-09 17:35:14 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-02-09 17:39:19 +0100
commit24209c3cb464a5e4bce1c0964771113b6f13638c (patch)
treedf0742df14dad97f3283069b736adec7581e519c /dev-python
parentflag-o-matic.eclass: whitelist -fstack-check #607710 (diff)
downloadgentoo-24209c3cb464a5e4bce1c0964771113b6f13638c.tar.gz
gentoo-24209c3cb464a5e4bce1c0964771113b6f13638c.tar.bz2
gentoo-24209c3cb464a5e4bce1c0964771113b6f13638c.zip
dev-python/jinja: Bump to version 2.9.5
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/jinja/Manifest1
-rw-r--r--dev-python/jinja/jinja-2.9.5.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/jinja/Manifest b/dev-python/jinja/Manifest
index 9be0c27848f9..2af5a4967e0d 100644
--- a/dev-python/jinja/Manifest
+++ b/dev-python/jinja/Manifest
@@ -3,3 +3,4 @@ DIST Jinja2-2.8.1.tar.gz 358129 SHA256 35341f3a97b46327b3ef1eb624aadea87a535b8f5
DIST Jinja2-2.8.tar.gz 357055 SHA256 bc1ff2ff88dbfacefde4ddde471d1417d3b304e8df103a7a9437d47269201bf4 SHA512 2e80d6d9ad10dafcce1e6dd24493f5dffc43a17f71a30a650415638e12d3a3891738ebacc569701129214026d062d91a2b10e4f7a2c7b85d801dde26ded1bebb WHIRLPOOL 31adc38738848aa224cceb0d0afb2b85eb080d166ed84f145eb0576eeedfb91cf8d99d7c98b6a6cc6ab4fedf33fdbe3171c80fd559df48036a7441232702e749
DIST jinja-2.9.3.tar.gz 415502 SHA256 1ddce1c6a45de023692aa56c2b68232dbeac6ffd83741b3876ee36f1a1a4e704 SHA512 7f5fdfde6b8c64050a27c39460ec9907cab52afe49aff83ec38ac8ad92ef97c8e592efefc633cd2a95336b551fd6a1adfeb92446aa53c5a2a8765d03feab8311 WHIRLPOOL 6fccde87f7f3c77a619a0e005118abb4f59964610a314df932c60477b45e7a18a681c3103f55f150fd8a0b83938f845577c249e9cd5b16442f6044a505b27e73
DIST jinja-2.9.4.tar.gz 416465 SHA256 7e7dc5aca0d4e39814a138e360284ad3d92647f480df4236e355acc542f5413b SHA512 60764e31878478c5b5adb60da8ddb8afd5d0982733728b87340f03abb5ad9092350ff8374d42cbd5be84d08904d06f0dbda2ef05f4dfbdc30110af9ab2472e5e WHIRLPOOL 8c0c34691f51373c64a158e043fd8ead01bd7454905ccf1a901901c52da80d35264023b7a65aa5878b87630b323d13d7cfae2470e472cb0204618ae9f607c99a
+DIST jinja-2.9.5.tar.gz 486763 SHA256 86baad86b1210856d784ddf0d243b8fa043f65b1e3cbc07e4fb24cd5b9725d89 SHA512 15c1b79981c4d6fcbb7fa947fe0fd7e43973433c03d6549a84deec8ad70881f7fd0d3a35160bf6371361994f838da7eb478c577de2612e004679ae51bd97b121 WHIRLPOOL 8ef540e81c40b72dbf652b73a63577e052813bc3d263340f55181c9a2320fa8e3f65c37ccaa6f4840d79b63c1c47f12070ae76d61be6fe0a93104e3916a7ff36
diff --git a/dev-python/jinja/jinja-2.9.5.ebuild b/dev-python/jinja/jinja-2.9.5.ebuild
new file mode 100644
index 000000000000..93c6e76ad5e6
--- /dev/null
+++ b/dev-python/jinja/jinja-2.9.5.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit eutils distutils-r1
+
+DESCRIPTION="A full-featured template engine for Python"
+HOMEPAGE="http://jinja.pocoo.org/ https://pypi.python.org/pypi/Jinja2"
+
+# pypi tarball is missing tests
+SRC_URI="https://github.com/pallets/jinja/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/markupsafe[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ !dev-python/jinja:compat"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+# XXX: handle Babel better?
+
+wrap_opts() {
+ local mydistutilsargs=()
+
+ if [[ ${EPYTHON} == python* ]]; then
+ mydistutilargs+=( --with-debugsupport )
+ fi
+
+ "${@}"
+}
+
+python_compile() {
+ wrap_opts distutils-r1_python_compile
+ if [[ ${EPYTHON} == python3.2 ]]; then
+ 2to3 --no-diffs -n -w -f unicode "${BUILD_DIR}/lib" || die
+ fi
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ if use examples ; then
+ docinto examples
+ dodoc -r examples/.
+ fi
+
+ distutils-r1_python_install_all
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ext/Vim/*
+}
+
+pkg_postinst() {
+ if ! has_version dev-python/Babel; then
+ elog "For i18n support, please emerge dev-python/Babel."
+ fi
+}