summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-05 16:43:15 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-05 16:52:55 +0200
commit1c76c72ee26583df2dc3237ab00b789f0d04401e (patch)
treedb9aa4cb7dc1b61cb300b0e6f61475d3db609829 /dev-python
parentdev-python/psycopg: Bump to 3.1.10 (diff)
downloadgentoo-1c76c72ee26583df2dc3237ab00b789f0d04401e.tar.gz
gentoo-1c76c72ee26583df2dc3237ab00b789f0d04401e.tar.bz2
gentoo-1c76c72ee26583df2dc3237ab00b789f0d04401e.zip
dev-python/psycopg: Bump to 2.9.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/psycopg/Manifest1
-rw-r--r--dev-python/psycopg/psycopg-2.9.7.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/psycopg/Manifest b/dev-python/psycopg/Manifest
index d2b974f5670c..d58e5972e327 100644
--- a/dev-python/psycopg/Manifest
+++ b/dev-python/psycopg/Manifest
@@ -2,3 +2,4 @@ DIST psycopg-3.1.10.gh.tar.gz 490875 BLAKE2B 26b82aa34f0eecc3e15943390b74d82e838
DIST psycopg-3.1.8.gh.tar.gz 483283 BLAKE2B 29141637c359b5ff8988753ee4e492b0aaf82bfc6445e0c5e1d9ef18f59f09ab071ce9a6183f2d864b62e85a109b24afbdd96248c00c8bb5c01357b06648ebba SHA512 4424305debc7b055fcd19b27714df46d54f8ae38452d8d5a3276df70a6c27e0094081020fdf2c34c73275cb058054414ac80843bb3e6a841bb3556ce39c76287
DIST psycopg-3.1.9.gh.tar.gz 487052 BLAKE2B 0422742d21b872c927d8df5f85e8e64fbfc912d08db85dbb1675fa64ccec4bd849b05b1f4773898b791edf0fbcd1aa0fe2c8bc210fd1672f70fba24df10b3624 SHA512 84e48b8fa7c8f677e193585e69e31dd43b8b55379f2370753e2af99351be25c2eba0bc66f19cb1ed65b8762123cc7a8d10023810815c53a8c963c6b743822766
DIST psycopg2-2.9.4.tar.gz 384017 BLAKE2B 4bc0afcc890c8a257c1ccd5c6e4e5301857a80f8b1428aa46c1473c9e18f5d2914a2e592c13336b06106217bb334d9b0321835bdd123f1627cbeb29dedf97bf7 SHA512 259088e42e0ab0d8a1a0ccf04f5e560f32c6179b4a0a0059e91bcf269baa8f4b0f1f949c332c640a2438c927a29b2c144078a861f8e18ba9c764da7c93c73b8d
+DIST psycopg2-2.9.7.tar.gz 383496 BLAKE2B ebec20330ed5e8f1e6190ebbbf9b7a2127e260a3979d63b5dc376843d549412d3b5157a471c00562ff2111c4f3d45c6fd18aa5682368057a90a78a8616eb62be SHA512 77f9136989ce035dc66eec47271bd2e18606db0637eb34300b0b95895358499dae2f5f714ce49d817070f949ec9daa46d221861449cce75225c15c19e757c1a3
diff --git a/dev-python/psycopg/psycopg-2.9.7.ebuild b/dev-python/psycopg/psycopg-2.9.7.ebuild
new file mode 100644
index 000000000000..31d20d1bc4cc
--- /dev/null
+++ b/dev-python/psycopg/psycopg-2.9.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN="psycopg2"
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="
+ https://www.psycopg.org/
+ https://pypi.org/project/psycopg2/
+ https://pypi.org/project/psycopg2/
+"
+
+LICENSE="LGPL-3+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="debug test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-db/postgresql-8.1:*"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? ( >=dev-db/postgresql-8.1[server] )
+"
+
+python_prepare_all() {
+ if use debug; then
+ sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+src_test() {
+ initdb -D "${T}"/pgsql || die
+ # TODO: random port
+ pg_ctl -w -D "${T}"/pgsql start \
+ -o "-h '' -k '${T}'" || die
+ createdb -h "${T}" psycopg2_test || die
+
+ local -x PSYCOPG2_TESTDB_HOST="${T}"
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${T}"/pgsql stop || die
+}
+
+python_test() {
+ "${EPYTHON}" -c "
+import tests
+tests.unittest.main(defaultTest='tests.test_suite')
+" --verbose || die "Tests fail with ${EPYTHON}"
+}