summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-05 17:21:01 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-05 17:21:01 +0200
commit19fa91290561087e106dccda54c48e50868cd23c (patch)
tree2020bbf536eb958e96ccf91659e8a8dfa4ec14c6 /dev-python
parentdev-cpp/catch: Stabilize 3.4.0 arm64, #911757 (diff)
downloadgentoo-19fa91290561087e106dccda54c48e50868cd23c.tar.gz
gentoo-19fa91290561087e106dccda54c48e50868cd23c.tar.bz2
gentoo-19fa91290561087e106dccda54c48e50868cd23c.zip
dev-python/anyio: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/anyio/Manifest1
-rw-r--r--dev-python/anyio/anyio-3.7.0.ebuild70
2 files changed, 0 insertions, 71 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index 5d7796fd8bef..cd91e403df40 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,2 +1 @@
-DIST anyio-3.7.0.tar.gz 142737 BLAKE2B f27b6c854f8861c760a922542471b5d7714cd54da0fa999a6efc8e394b49e538e7689147834a4076e1970932416fabe820923c2155048d943eee697454771c8f SHA512 0793012dc364d2bb27ebae8a23f275ecd24d444de750fbebcb72e70ca465a3be9c69938543e1a3c686abfff3ed9036974b38e3886fb24a110a9ef307a82d3f0b
DIST anyio-3.7.1.tar.gz 142927 BLAKE2B 80a093943fbd23069e9511a83b3eb1e27f2863b11e184709f92cab2dfebc05ea3c291d22be4b1e79d00ae52e10009d5fb2c664730009b40e2b666587538d0ca5 SHA512 067bbffa9e0d6ce339a4999a677c857e839aa3bf5a056d841fec8cbd3be17023c9158df907ff66b9a5437a78158bc9bbb3b9ebe30c57ef98660642bc057d7d10
diff --git a/dev-python/anyio/anyio-3.7.0.ebuild b/dev-python/anyio/anyio-3.7.0.ebuild
deleted file mode 100644
index 83b3635bd1a7..000000000000
--- a/dev-python/anyio/anyio-3.7.0.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
-HOMEPAGE="
- https://github.com/agronholm/anyio/
- https://pypi.org/project/anyio/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- dev-python/exceptiongroup[${PYTHON_USEDEP}]
- ' 3.{9..10})
- >=dev-python/idna-2.8[${PYTHON_USEDEP}]
- >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
-"
-# On amd64, let's get more test coverage by dragging in uvloop, but let's
-# not bother on other arches where uvloop may not be supported.
-BDEPEND="
- >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
- >=dev-python/psutil-5.9[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
- dev-python/trio[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- amd64? (
- $(python_gen_cond_dep '
- >=dev-python/uvloop-0.17[${PYTHON_USEDEP}]
- ' python3_{10..11})
- )
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- dev-python/sphinx-rtd-theme \
- dev-python/sphinx-autodoc-typehints
-
-python_test() {
- local EPYTEST_DESELECT=(
- # requires link-local IPv6 interface
- tests/test_sockets.py::TestTCPListener::test_bind_link_local
-
- # trio-0.22?
- 'tests/test_sockets.py::TestTCPStream::test_connection_refused[trio-multi]'
- 'tests/test_taskgroups.py::test_exception_group_children[trio]'
- 'tests/test_taskgroups.py::test_exception_group_host[trio]'
- 'tests/test_taskgroups.py::test_exception_group_filtering[trio]'
- )
- if [[ ${EPYTHON} == python3.12 ]]; then
- EPYTEST_DESELECT+=(
- tests/test_fileio.py::TestPath::test_properties
- )
- fi
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -m 'not network'
-}