summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-04 03:55:25 +0000
committerSam James <sam@gentoo.org>2021-03-04 03:55:25 +0000
commit0e17b9d54e6beb648c8884b9bd8d7656b07cbed1 (patch)
treeef607e090f436b8bb5f7a84d681bca07b7ad8dfa /dev-python
parentdev-python/nose_fixes: mark ALLARCHES (diff)
downloadgentoo-0e17b9d54e6beb648c8884b9bd8d7656b07cbed1.tar.gz
gentoo-0e17b9d54e6beb648c8884b9bd8d7656b07cbed1.tar.bz2
gentoo-0e17b9d54e6beb648c8884b9bd8d7656b07cbed1.zip
dev-python/nose-exclude: add Python 3.9
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nose-exclude/nose-exclude-0.5.0-r1.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/dev-python/nose-exclude/nose-exclude-0.5.0-r1.ebuild b/dev-python/nose-exclude/nose-exclude-0.5.0-r1.ebuild
index 7c1729f4a570..5a82bbe040dc 100644
--- a/dev-python/nose-exclude/nose-exclude-0.5.0-r1.ebuild
+++ b/dev-python/nose-exclude/nose-exclude-0.5.0-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} pypy3 )
+PYTHON_COMPAT=( python3_{7,8,9} pypy3 )
inherit distutils-r1
@@ -15,9 +15,6 @@ LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 s390 sparc x86"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
-python_test() {
- esetup.py test
-}
+distutils_enable_tests setup.py