summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-09 17:23:02 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-09 17:30:48 +0200
commit0a57d6c6160be3c2ecff5aea62ada10e0e29fe35 (patch)
treef75c92c3b880756d92ef90ffcaa9030bba35d4ad /dev-python
parentdev-python/greenlet: Enable py3.13 (diff)
downloadgentoo-0a57d6c6160be3c2ecff5aea62ada10e0e29fe35.tar.gz
gentoo-0a57d6c6160be3c2ecff5aea62ada10e0e29fe35.tar.bz2
gentoo-0a57d6c6160be3c2ecff5aea62ada10e0e29fe35.zip
dev-python/pytest-twisted: Enable py3.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild b/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild
index d9db61f8173e..f90693d8ef2f 100644
--- a/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild
+++ b/dev-python/pytest-twisted/pytest-twisted-1.14.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
@@ -52,5 +52,11 @@ python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=pytest_twisted
+ local EPYTEST_DESELECT=(
+ # regression with pytest-8.2
+ # https://github.com/pytest-dev/pytest-twisted/issues/176
+ testing/test_basic.py::test_async_fixture_module_scope
+ )
+
epytest -p pytester
}