summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/zsi
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/zsi')
-rw-r--r--dev-python/zsi/Manifest1
-rw-r--r--dev-python/zsi/metadata.xml15
-rw-r--r--dev-python/zsi/zsi-2.1_alpha1-r1.ebuild55
3 files changed, 71 insertions, 0 deletions
diff --git a/dev-python/zsi/Manifest b/dev-python/zsi/Manifest
new file mode 100644
index 000000000000..b284bbba10d9
--- /dev/null
+++ b/dev-python/zsi/Manifest
@@ -0,0 +1 @@
+DIST ZSI-2.1-a1.tar.gz 932958 SHA256 253cd6968bc52e66121ee370831b93be385d65563a0e71c9c704db83901bf244 SHA512 13f8734a5b09caa83786e776bc1104061812d05543b1412cda02dd904d6cd926042a4a882ffac71081a5275879d79927ea225ae2753936e0d026aee074f07974 WHIRLPOOL 36eaa489579be09559c158cc2484cc63d628bfe5ac6239b6b00ea27760281c4ddc1b59cb01c6d551fcedadfd4d39bad8e9fa0ed86789222193052843fb87b963
diff --git a/dev-python/zsi/metadata.xml b/dev-python/zsi/metadata.xml
new file mode 100644
index 000000000000..3f075e5dae5d
--- /dev/null
+++ b/dev-python/zsi/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>angelos@gentoo.org</email>
+ <name>Christoph Mende</name>
+ </maintainer>
+ <use>
+ <flag name="twisted">add support for <pkg>dev-python/twisted</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">pywebsvcs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/zsi/zsi-2.1_alpha1-r1.ebuild b/dev-python/zsi/zsi-2.1_alpha1-r1.ebuild
new file mode 100644
index 000000000000..21837dca243e
--- /dev/null
+++ b/dev-python/zsi/zsi-2.1_alpha1-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="ZSI"
+MY_P="${MY_PN}-${PV/_alpha/-a}"
+
+DESCRIPTION="Web Services for Python"
+HOMEPAGE="http://pywebsvcs.sourceforge.net/zsi.html"
+SRC_URI="mirror://sourceforge/pywebsvcs/${MY_P}.tar.gz"
+
+LICENSE="BSD MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc examples twisted"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ twisted? (
+ dev-python/twisted-core
+ dev-python/twisted-web
+ )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ if ! use twisted; then
+ sed -i \
+ -e "/version_info/d"\
+ -e "/ZSI.twisted/d"\
+ setup.py || die "sed failed"
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use doc; then
+ dohtml doc/*.{html,css,png}
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r doc/examples/* samples/*
+ fi
+}