summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-15 08:26:58 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-15 10:23:34 +0200
commit061312f228de71fd152c5d68981003d95cbcc102 (patch)
tree72bd7b2709c3f3fcc355da4ed77938032f799cc7 /dev-python/zope-component/zope-component-6.0.ebuild
parentdev-python/feedgenerator: Bump to 2.1.0 (diff)
downloadgentoo-061312f228de71fd152c5d68981003d95cbcc102.tar.gz
gentoo-061312f228de71fd152c5d68981003d95cbcc102.tar.bz2
gentoo-061312f228de71fd152c5d68981003d95cbcc102.zip
dev-python/zope-component: Bump to 6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/zope-component/zope-component-6.0.ebuild')
-rw-r--r--dev-python/zope-component/zope-component-6.0.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/zope-component/zope-component-6.0.ebuild b/dev-python/zope-component/zope-component-6.0.ebuild
new file mode 100644
index 000000000000..6fb232cd00ac
--- /dev/null
+++ b/dev-python/zope-component/zope-component-6.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Zope Component Architecture"
+HOMEPAGE="
+ https://pypi.org/project/zope.component/
+ https://github.com/zopefoundation/zope.component/
+"
+
+LICENSE="ZPL"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/zope-event[${PYTHON_USEDEP}]
+ >=dev-python/zope-hookable-4.2.0[${PYTHON_USEDEP}]
+ >=dev-python/zope-interface-5.3.0[${PYTHON_USEDEP}]
+ !dev-python/namespace-zope
+"
+BDEPEND="
+ test? (
+ dev-python/zope-configuration[${PYTHON_USEDEP}]
+ dev-python/zope-i18nmessageid[${PYTHON_USEDEP}]
+ dev-python/zope-testing[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # strip rdep specific to namespaces
+ sed -i -e "/'setuptools'/d" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ distutils_write_namespace zope
+ eunittest
+}