summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-18 08:36:49 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-18 08:59:50 +0200
commit9ddbcc51376d09ef36eeab749139165201873e29 (patch)
tree77956f8bb62b86a7dbe9796496c68fe20ddc2edd /dev-python/yarl
parentdev-python/httpretty: Extend optional test deps to py3.11 (diff)
downloadgentoo-9ddbcc51376d09ef36eeab749139165201873e29.tar.gz
gentoo-9ddbcc51376d09ef36eeab749139165201873e29.tar.bz2
gentoo-9ddbcc51376d09ef36eeab749139165201873e29.zip
dev-python/yarl: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/yarl')
-rw-r--r--dev-python/yarl/Manifest1
-rw-r--r--dev-python/yarl/yarl-1.7.2-r3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/yarl/Manifest b/dev-python/yarl/Manifest
index b1b79a50c5f5..39248b719129 100644
--- a/dev-python/yarl/Manifest
+++ b/dev-python/yarl/Manifest
@@ -1 +1,2 @@
+DIST yarl-1.7.2.gh.tar.gz 108115 BLAKE2B 7bd212b652a77ac29fde4c6565c48c4067f2a24db6bbf735107f3dfa5ee8b6ad2e5a5c3c6206e8dc7692e4cfd5c975d4304dd93280087574bddd73a337417c52 SHA512 bf69c5758f523259757ff84a8737e28931f46311f12f6e141329a5074d34a0cfb45795bf79cb7b78cb676ca7bc38042a2fbd946a5f41bf1d149ada50b88b31ae
DIST yarl-1.7.2.tar.gz 168562 BLAKE2B 7da82193e9fa0d317bd4ba46d63ce04a36c95fc3a389d6800d12e0ddecaacb41c07a665db9e731a9112d98a0f3133861b174dc62523da202d0d06f4cb995c354 SHA512 ac5b630dd592ffa8b095e4d7eee2facaeac8ab578e55fd8856c6a6349f514081020c707cd0b33f250c0e78133e92ed6156835660f14c5ae54d60b4fdf6ea50ea
diff --git a/dev-python/yarl/yarl-1.7.2-r3.ebuild b/dev-python/yarl/yarl-1.7.2-r3.ebuild
new file mode 100644
index 000000000000..1f6c79fa64c5
--- /dev/null
+++ b/dev-python/yarl/yarl-1.7.2-r3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Yet another URL library"
+HOMEPAGE="
+ https://github.com/aio-libs/yarl/
+ https://pypi.org/project/yarl/
+"
+SRC_URI="
+ https://github.com/aio-libs/yarl/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/multidict-4.0[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/alabaster
+
+src_configure() {
+ > .install-cython || die
+ emake cythonize
+}
+
+python_test() {
+ cd tests || die
+ epytest --override-ini=addopts=
+}