summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-05 04:53:01 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-05 04:53:01 +0200
commite48b8d4fca9a582284a2bb690ba021fabecb7c41 (patch)
tree1ecc564305f3ecca29ab59c9161c1cd5aafcf7e2 /dev-python/xxhash
parentdev-python/nbconvert: Bump to 7.9.2 (diff)
downloadgentoo-e48b8d4fca9a582284a2bb690ba021fabecb7c41.tar.gz
gentoo-e48b8d4fca9a582284a2bb690ba021fabecb7c41.tar.bz2
gentoo-e48b8d4fca9a582284a2bb690ba021fabecb7c41.zip
dev-python/xxhash: Bump to 3.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xxhash')
-rw-r--r--dev-python/xxhash/Manifest1
-rw-r--r--dev-python/xxhash/xxhash-3.4.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/xxhash/Manifest b/dev-python/xxhash/Manifest
index fc5308e36143..683477f2d2ae 100644
--- a/dev-python/xxhash/Manifest
+++ b/dev-python/xxhash/Manifest
@@ -1 +1,2 @@
DIST xxhash-3.3.0.tar.gz 84262 BLAKE2B 9655bed8c30e8ecc7b3f12bebe9f845412e4fbc24daef11570eb8bf78deaf78fe4ea874a5ed334c965c055e6ad4e32f03f025d3ed815bb7a2249e8f80a0b04b0 SHA512 1418e0ff8d7dca7759bfe048ee42c2b1168b68ec69f431622f065c28bcf65b2e21f5951a8651f2151a17f8d1b19b47d5c305a545ae1e0d427c7cadf29e94b968
+DIST xxhash-3.4.1.tar.gz 84220 BLAKE2B 9bf0bc3ea15adbcf9c1b0dd526f406bd20ca11b6c25c2c771e34952d9bd3d2e85d121304bebfe47590573b4da73acf28d1726d0c628239ec9591738462cee3c0 SHA512 ab3c1fa5ce3ebefa13f87c60a700a897a080c576f1ce492bae9c47eb24a9d182cc8e71bfed81c8f0413ee261fd5522bdf44187043c9703958b72fa77e46a8953
diff --git a/dev-python/xxhash/xxhash-3.4.1.ebuild b/dev-python/xxhash/xxhash-3.4.1.ebuild
new file mode 100644
index 000000000000..b271bad65166
--- /dev/null
+++ b/dev-python/xxhash/xxhash-3.4.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Python binding for the xxHash library"
+HOMEPAGE="
+ https://github.com/ifduyue/python-xxhash/
+ https://pypi.org/project/xxhash/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ >=dev-libs/xxhash-0.8.0
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+distutils_enable_tests unittest
+
+python_configure_all() {
+ export XXHASH_LINK_SO=1
+}
+
+python_test() {
+ cd tests || die
+ eunittest
+}