summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-05 17:52:01 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-05 18:07:03 +0100
commit17a4a2c8e93f09db8111dc4e560356186e5d9975 (patch)
tree207837471355d401af1d51b03ccbde49547830b2 /dev-python/xlsxwriter
parentdev-python/mkdocs-material: Bump to 9.0.11 (diff)
downloadgentoo-17a4a2c8e93f09db8111dc4e560356186e5d9975.tar.gz
gentoo-17a4a2c8e93f09db8111dc4e560356186e5d9975.tar.bz2
gentoo-17a4a2c8e93f09db8111dc4e560356186e5d9975.zip
dev-python/xlsxwriter: Bump to 3.0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/xlsxwriter')
-rw-r--r--dev-python/xlsxwriter/Manifest1
-rw-r--r--dev-python/xlsxwriter/xlsxwriter-3.0.8.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/xlsxwriter/Manifest b/dev-python/xlsxwriter/Manifest
index 96d0fb85a4e3..4ce53697a4e9 100644
--- a/dev-python/xlsxwriter/Manifest
+++ b/dev-python/xlsxwriter/Manifest
@@ -1 +1,2 @@
DIST XlsxWriter-RELEASE_3.0.7.gh.tar.gz 35214702 BLAKE2B 8af7a7da9f2e6fd3a8f794f906935ed9dc1389a710d8b60fbf74e419829e6d233ad122d8ce75de93a6d3229e394277fadd76239aac73e8949f7c4737430a0859 SHA512 e80b9cfa741984db5b0aebd083c0a3c12f987b1a851088bc16e52b56cadb69feb1b795c1061ebde56c7ab1bf17d7899e90b42facd45bcacf5ce6c7070208e6e9
+DIST XlsxWriter-RELEASE_3.0.8.gh.tar.gz 35224268 BLAKE2B 593236a4fa9aaa5fde3920cf3af4819afcc026b14160b61de41f7186ff594611a7f08e2a1befbd5a060f4f84c0f2541c773153c311154d1a94bba7260ae650f7 SHA512 c03e518cf517803f006fc13d314a40e54f47e4156ea16d46be023f3af727edd02aedbfe0e15da019fcec2b4f160643846f86c80c80d93be421cef33f1d11dae7
diff --git a/dev-python/xlsxwriter/xlsxwriter-3.0.8.ebuild b/dev-python/xlsxwriter/xlsxwriter-3.0.8.ebuild
new file mode 100644
index 000000000000..b9643a5b3c75
--- /dev/null
+++ b/dev-python/xlsxwriter/xlsxwriter-3.0.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1
+
+TAG=RELEASE_${PV}
+MY_P=XlsxWriter-${TAG}
+DESCRIPTION="Python module for creating Excel XLSX files"
+HOMEPAGE="
+ https://github.com/jmcnamara/XlsxWriter/
+ https://pypi.org/project/XlsxWriter/
+"
+SRC_URI="
+ https://github.com/jmcnamara/XlsxWriter/archive/${TAG}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest